cancel
Showing results for 
Search instead for 
Did you mean: 

Black screen on start on Quest 2 (Unity)

rwblodgett
Level 4

I am now using Unity 2019.4.36, recently updated from Unity 2019.4.23.  I rebuilt my Quest 2 project and deployed to the device and now it launches a black screen.

 

Trying to unravel what has changed/not changed.

 

I'm using Android API 30.  Is this the correct version?

I upgraded the Oculus XR plugin in package manager to 1.12.0 and still doesn't work.  I was on 1.11.2.

I tried building with Vulkan instead of OpenGLES3, but still doesn't work.

I have tried toggling a few other settings like "Low Overhead Mode", but still doesn't work.

I have tried toggling Multithreaded mode, but still doesn't work.

 

Quest OS updated in the meantime as well to now include the Meta logo on startup instead of Oculus logo, but still no luck.

 

I do notice this obscure opengl error when not using Vulkan.  With Vulkan, no error.

 

Quest OPENGL NATIVE PLUG-IN ERROR: GL_INVALID_OPERATION: Operation illegal in current state (Filename: ./Runtime/GfxDevice/opengles/GfxDeviceGLES.cpp Line: 444)

 

1 ACCEPTED SOLUTION

Accepted Solutions

rwblodgett
Level 4

Okay, I figured it out.

 

The OpenGL error was not related.

 

It turns out I had a setting "Default Orientation" set to "Portrait" in the Player / Other Settings options in Unity.

 

Apparently between Unity 2019.4.23 and later versions, this setting was made to affect the Quest build.  This causes the RESOLUTION requested of Quest to be FLIPPED.  And therefore completely screwed up and displays as a black screen.  (You have to force restart the Quest to get it back to normal).

 

Instead if you choose "Auto Rotation" as the default orientation, then everything launches fine!

View solution in original post

1 REPLY 1

rwblodgett
Level 4

Okay, I figured it out.

 

The OpenGL error was not related.

 

It turns out I had a setting "Default Orientation" set to "Portrait" in the Player / Other Settings options in Unity.

 

Apparently between Unity 2019.4.23 and later versions, this setting was made to affect the Quest build.  This causes the RESOLUTION requested of Quest to be FLIPPED.  And therefore completely screwed up and displays as a black screen.  (You have to force restart the Quest to get it back to normal).

 

Instead if you choose "Auto Rotation" as the default orientation, then everything launches fine!