Showing results for 
Search instead for 
Did you mean: 

FFR not enabled via ADB on Quest 2 - MOVED FROM GENERAL

Hi I am pretty new to this so apologies if I have missed something.


I have tried enabling FFR via ADB on both Quest 1 and 2 however it doesn not appear to be working on the quest 2. Command used:
adb shell setprop debug.oculus.foveation.level 4


This shows up in the Home on Quest 1 but has no effect on 2. I have removed the headset foam so I can see right to the edge of the screen. Can anyone provide any insight?





Not applicable

You haven't said what setup you're using (Unity, Unreal, native, etc.) or what the adb command you're using is. If you enable FFR via adb you should see it everywhere, including the Oculus Quest Home environment and any games you launch after entering the command.


You won't see it in Quest Link apps. Also there are bugs in Unity's URP pipeline that can break FFR, so you might not see it in a Unity app.

Hey thanks for the reply Dark Table!


Here's the command I used:
adb shell setprop debug.oculus.foveation.level 4


I have tried through a command console via SSH and Sidequest and am seeing the change on Quest 1  home but not on Quest 2 - I'm not using link. 

Any idea why the same command works for Quest 1 but not Quest 2 - have tried on 2 different headsets without any luck.


Thanks again!


Level 4

Bump!  This has caused devs grief trying to determine why the plug-in isn't working, when in fact it's the device itself!  Please fix!

Not applicable

If you want to set FFR levels from this adb command you need to disable dynamic fixed foveated rendering first. This appears to be on by default on the Quest 2.



adb shell setprop debug.oculus.foveation.dynamic 0