cancel
Showing results for 
Search instead for 
Did you mean: 

Hand tracking -> no hands rendering

julien_cifre_3
Level 2
Hello, 
I'm trying to test the hands interactions train scene, but have no hands rendering in the scene. Same with the hand test scene. All seems to be well configured but still no hands input visible on the scene (the gesture to get the menu is working).
Anyone know what the problem could be ?

Linkos
18 REPLIES 18

hogehuga
Level 2
Hi.
Same with me, man.
I wanna know the reason, too.

Have you already find any solution?
In my project, this AndroidManifest.xml  exists in the path, /Assets/Plugins/Android/ . 

However, hands would not render in the scene.

Anyone know what the problem could be? (Sorry for the piggybacking.)

--
(Edited)
sorry, i can't post my .xml file. it is too long. but i think it is the simplest one.

Hanabear
Level 4
in the Inspector panel of OVRCameraRig, find hand tracking support, change "controller only" to "controller and hands"

julien_cifre_3
Level 2

Hanabear said:

in the Inspector panel of OVRCameraRig, find hand tracking support, change "controller only" to "controller and hands"


I've allready done that with no result. All the config was ok, but with no result.
But i've now find a solution, I upgrade my Unity version to 2019.2 (I was using the 2018.3 version previously) and it suddenly works like a charm.

hogehuga
Level 2
Thanks for comments, guys.

I have tried other versions of Unity3D, 2018.3, 2019.2 and 2019.3.
In my case, however, hands do not render in applications.
All the config was ok too.. ( including hand tracking support in OVRCameraRig. :wink: )

Anyway, i will keep to solve the problem with using Unity3D 2019.2, thx. 🙂

cazforshort
Level 5
Are you running it with Link? 

Currently hand tracking doesn't work with Link so you need to do "Build and Run" to test. 
1) Plug in your headset.
2) In the headset cancel any and all Oculus Link Requests 
3) In Unity, click Build Settings, then add your scene, then click Build and run.
4) In the headset make sure your on hands mode and  wait for the app to automatically launch. 
Remember, No Oculus Link

Weitin
Level 4
Do you have app IDs set for both the options in Resources > OvrAvatarSettings? OvrAvatar won't render without an ID.

hogehuga
Level 2


Are you running it with Link? 

Currently hand tracking doesn't work with Link so you need to do "Build and Run" to test. 
1) Plug in your headset.
2) In the headset cancel any and all Oculus Link Requests 
3) In Unity, click Build Settings, then add your scene, then click Build and run.
4) In the headset make sure your on hands mode and  wait for the app to automatically launch. 
Remember, No Oculus Link
Thx!

Actually, i have experience to use Oculus Link. however, i have already uninstalled Oculus App from my laptop. so i think current state is No Oculus Link. is that right?

hogehuga
Level 2
Weitin said:
Thx, too!
I created new app, with Go & GearVR platform, from my dashboard and set AppID (not User ID) for /Resources/OVRAvatarSettings and /Resources/OculusPlatformSettings.
After that, I tried same steps in the document, unity-handtracking. 
but, no result..

The white skin of Hands are rendered, in case CustomHands and GuardianBoundarySystem scenes.
Does this mean that i succeeded to render OvrAvater's objects?

hogehuga
Level 2
Finally, i got succeeded. 
After all, i can't found the critical reason.
Solutions i have tried can be mainly divided into two parts. i think these have worked.
- Updating UnityHub
- Uninstalling and Installing android SDK/NDK.

anyway, thx all.