Showing results for 
Search instead for 
Did you mean: 

Multiple issues getting Unreal project onto AppLab (Solved)

Level 3

Hi all,

My team and I are trying to get our Quest app onto the AppLab.  However, the developers are running into a couple of issues.  This will be the first project we've launched onto the Oculus store(s) and are having a lot of trouble with finding answers to our issues.
The issues are as follows (we are using Unreal 4.23, built from source via the Oculus GIT):

1. The app must be 'focus aware', which makes sense.  However, despite checking the "hasInputFocus" variable each frame, we are still being told to set the manifest tag.  In 4.23 there is no 'tickbox' to set this, so it has to be done manually.  We've tried adding "\nandroid:name="com.oculus.vr.focusaware" android:value="true" to our "<activity section> under Advanced APK Packaging (the \n is to separate from the previous line), but are still getting the error when we try to upload. What are we missing?

Solution Found: The manifest entry has been changed to read as <meta-data android:name="com.oculus.vr.focusaware" android:value="true"/>\n[other manifest lines]. This removes the error when attempting to upload the software to Oculus.  The "<meta-data" part is essential.

2. When we try to build a distribution build, we are told that the "com.oculusvr.svclib does no exist".  As far as we can tell, this is possibly something to do with GearVR and entitlement checks, but we are checking for entitlement via the "VerifyEntitlement" node and we aren't building for GearVR...

Solution Found: After setting the packaging to build for distribution another change had to be made.  In the Project Settings > Platforms/Android section, under "Advanced APK Packagain" the option for "Remove Oculus Signature Files from Distribution APK" had to be unticked.

We really appreciate any and all help that's offered. Thanks.