cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Integration 31.2 Passthrough works, broken when i upgrade to v33?

GlassBall
Level 3

Hi!

My program, Custom Home Mapper, uses pass-through features.  I released an update when v31.2 was available and integrated AR features into a dozen minigames, really opened up the usability and functionality of my app.

 

I'm worried, because passthrough ONLY works on Unity Oculus Integration v31.2. Had to jump through a lot of hoops to get it working, but I did it (yay?). Only now, with the rollout of firmware v34, nobody can use the passthrough features i wrote in version 31.2. (boo)

 

I know the SDK for v34 isn't out yet (tommorow, right?) but does anyone know what I need to change to make passthough functions on v32 or v33? We still require the OpenXR backend and IL2CPP, correct?

I don't think there are many devs doing big passthough projects like me, so i'm kinda stuck trying to find resources and info about how this sdk works. Makes me nervous that i cant run things on the newer integration packages, no errors, just passthrough doesn't show.

 

Curious to hear from devs runnning passthough on oculus integration v32 or v33.

5 REPLIES 5

Hyper_active
Level 3

Hey i've also fully integrated passthrough into my game and it's been there since v31 runs fine on v33. The hit list is still the same:

- OpenXR Backend

- IL2CPP

- Arm64

- Enable passthrough on OVRManager

- Allow passthrough in Manifest

- Allow experimental in Manifest

 

Though of it was working before for you then you were doing it right. And the same apk build worked on v31 and doesn't work on v33 ? 

 

Are you only talking about firmware version or also SDK versions updates? 

So your game SDK v31 worked, and now updated to v33 doesn't work?

 

Thanks for response! Sorry for confusion about integration vs public firmware release versions.

 

Yes, passthrough functions fine in Oculus unity integration SDK v31.2, I updated the game a few weeks back and users report having a good time. This is actually a collection of 12 games/apps, so it has a pretty robust implementation in a bunch of styles/modes. Public released build worked on my quest1 up until q1 hit firmware v34. Currently still works on my quest2, because i've stopped it from updating to v34 (is on firmware v33)

My assumption was that i'm going to have to update the integration package SDK to v34 when it comes out, otherwise my users will not be able to continue to use current AR/passthrough features (its deprecated, and v34 wont allow it). Am i correct that, even if i updated to integration package v33, that it still wont work on my firmware v34 quest? Does your app (on integration sdk v33) currently work on a firmware v34 quest?

 

Regardless, yes i've checked the right boxes, but perhaps the manifest is the issue? I never explicitly set anything, just allowed oculus to generate a store compatible one. Normally when i release one of my other games to applab, i export to android studio, edit the manifest directly, and then rebuild it, but I don't do that for the mapper since it isn't for applab. Is there a specific line i should be adding? surely, if i regenerate the manifest, it should add the appropriate lines to my unity built manifest, no?

 

 

 

Hyper_active
Level 3

Right, I understand now. 

That's a good question. I'm gonna test update to SDK to v33 and update one of my headsets to v34 and try right now. Hold on. 

Letting Oculus generate the Manifest will fill in the correct stuff for a store submission. So that's all good! Though I say that, as of SDK 34 there might be a new manifest permission that needs to be added to make it work, and we'll only know what it is once v34 is live. 🙂

thanks for the test!

already, you've helped me confirm that there's nothing drastic i need to change, everything _should_ be in order. I'll tweak and test stuff tommorow, got a few ideas.

Hyper_active
Level 3

I can confirm now that firmware v34 + SDK 33, passthrough doesn't work. Assume we need to wait for requirements to get it working with SDK 34. 

On another note have you managed to get the guardian points returned when using OpenXR backend? In the legacy backend this worked just fine:

OVRManager.boundary.GetGeometry(OVRBoundary.BoundaryType.OuterBoundary) 

 But then switching to OpenXR, it doesn't work anymore. So I can get passthrough, but no boundary points now.