cancel
Showing results for 
Search instead for 
Did you mean: 

Pairing Santa Cruz dev kit with Oculus App fails every time

azinicus2
Level 3
I have a Santa Cruz dev kit from early 2018 (EAS-M10) and ever since the firmware updated OTA a week ago I have been unable to pair the device with the Oculus App on any iOS device I own (I don't have an Android device to try this with).

I have tried:
  • Turning bluetooth on and off on both iOS devices I tried this with (an iPhone X and an iPad Air 2)
  • Restarting all devices
  • Trying to follow the instructions in the pairing process exactly - ie turning off the Quest while it's plugged in, turning it on at the appropriate time, etc
  • I tried leaving the Quest on over night to fully charge and hopefully do any more OTAs 
  • Tried factory reset via fastboot menu
  • Tried ADB logcat to see what happens during the pairing process, and it seems like the devices are communicating via bluetooth but maybe some connectivity issues on the device?
    03-21 19:48:24.531  1458  1767 W CompanionServer: No connection
    03-21 19:48:27.200 1245 1723 I bt_btm_ble: btm_ble_resolve_random_addr_on_conn_cmpl unable to match and resolve random address
    03-21 19:48:27.200 1245 1723 W bt_btm : btm_acl_created hci_handle=11 link_role=1 transport=2
    03-21 19:48:27.528 1245 1723 W bt_smp : smp_br_connect_callback is called on unexpected transport 2
    03-21 19:48:27.528 1245 1723 W bt_btm : btm_read_remote_version_complete: BDA: 5a-ab-aa-0d-aa-4e
    03-21 19:48:27.528 1245 1723 W bt_btm : btm_read_remote_version_complete lmp_version 9 manufacturer 15 lmp_subversion 16910
    03-21 19:48:27.528 1245 1723 E bt_btif : bta_dm_acl_change new acl connetion:count = 1
    03-21 19:48:27.528 1245 1723 W bt_btif : bta_dm_acl_change info: 0x0
    03-21 19:48:27.528 1245 1723 W bt_l2cap: L2CA_SetDesireRole() new:x1, disallow_switch:0
    03-21 19:48:27.529 1245 1360 D BtGatt.GattService: onConnected() connId=5, address=5A:AB:AA:0D:AA:4E, connected=true
    03-21 19:48:27.529 1245 1360 D bt_btif_dm: remote version info [5a:ab:aa:0d:aa:4e]: 0, 0, 0
    03-21 19:48:27.529 1245 1360 E BluetoothRemoteDevices: aclStateChangeCallback: Device is NULL
    03-21 19:48:27.529 1458 1470 D BluetoothGattServer: onServerConnectionState() - status=0 serverIf=5 device=5A:AB:AA:0D:AA:4E
    03-21 19:48:27.530 1458 1470 I com.oculus.companion.server.BleModule: GATT Connected to device: 5A:AB:AA:0D:AA:4E
    03-21 19:48:27.615 1245 1723 E bt_att : MTU request PDU with MTU size 517
    03-21 19:48:27.615 1245 1723 W bt_att : Call back not found for application conn_id=3
    03-21 19:48:27.615 1245 1723 W bt_att : Call back not found for application conn_id=4
    03-21 19:48:27.615 1245 1723 W bt_att : Call back not found for application conn_id=6
    03-21 19:48:27.615 1245 1360 D BtGatt.GattService: onMtuChanged() - connId=5, mtu=517
    03-21 19:48:27.616 1458 1472 D BluetoothGattServer: onMtuChanged() - device=5A:AB:AA:0D:AA:4E, mtu=517
    03-21 19:48:27.616 1458 1472 I com.oculus.companion.server.BleModule: Setting MTU to: 512
    03-21 19:48:28.037 1245 1360 D BtGatt.GattService: onResponseSendCompleted() handle=42
    03-21 19:48:28.099 1245 1360 D BtGatt.GattService: onResponseSendCompleted() handle=42
    03-21 19:48:28.100 1458 2469 D CompanionBLEReceiver: Received HELLO Request
    03-21 19:48:28.102 1458 2469 E com.oculus.companion.authentication.CertificateModule: !!!DeviceCert is null. Returning temp certificate!!!
    03-21 19:48:28.157 1245 1360 D BtGatt.GattService: onResponseSendCompleted() handle=42
    03-21 19:48:28.217 1245 1360 D BtGatt.GattService: onResponseSendCompleted() handle=42
    03-21 19:48:28.276 1245 1360 D BtGatt.GattService: onResponseSendCompleted() handle=42
    03-21 19:48:28.610 1245 1723 W bt_btif : bta_gattc_conn_cback() - cif=3 connected=0 conn_id=3 reason=0x0013
    03-21 19:48:28.610 1245 1723 W bt_btif : bta_gattc_conn_cback() - cif=4 connected=0 conn_id=4 reason=0x0013
    03-21 19:48:28.610 1245 1723 W bt_btif : bta_gattc_conn_cback() - cif=6 connected=0 conn_id=6 reason=0x0013
    03-21 19:48:28.610 1245 1723 I bt_btm_sec: btm_sec_disconnected clearing pending flag handle:11 reason:19
    03-21 19:48:28.610 1245 1723 W bt_l2cap: L2CA_SetDesireRole() new:x1, disallow_switch:0
    03-21 19:48:28.610 1245 1360 D BtGatt.GattService: onConnected() connId=5, address=5A:AB:AA:0D:AA:4E, connected=false
    03-21 19:48:28.611 1245 1360 E BluetoothRemoteDevices: aclStateChangeCallback: Device is NULL
    03-21 19:48:28.611 1458 1472 D BluetoothGattServer: onServerConnectionState() - status=0 serverIf=5 device=5A:AB:AA:0D:AA:4E
    03-21 19:48:28.611 1458 1472 I com.oculus.companion.server.BleModule: GATT Disconnected from device5A:AB:AA:0D:AA:4E
    03-21 19:48:28.611 1458 1767 W CompanionServer: No connection
    03-21 19:48:34.766 1835 2210 I OVRPlatform: [FBNS] ClientImpl.cpp:209 Failed to connect to the MQTT server (edge-mqtt.facebook.com:443): 15 Lookup error.
    03-21 19:48:34.766 1835 2210 I OVRPlatform: [FBNS] ClientImpl.cpp:127 Received a CONNACK without valid credentials

Happy non-informative screen I see till the end of time:
m4hcokdaidan.jpeg
3 REPLIES 3

Sklett
Level 2
I have the same exact issue. Have you gotten any help? (I've tried multiple iOs and android devices with the same results)

azinicus2
Level 3

Sklett said:

I have the same exact issue. Have you gotten any help? (I've tried multiple iOs and android devices with the same results)


I didn't get any help, but after a week or so it finally fixed itself. I tried a bunch of things but nothing worked except waiting it out.

Hello

 

This is an old thread but how did you manage to pair your Santa Cruz controllers?
My app doesn't detect my controllers at all...