Showing results for 
Search instead for 
Did you mean: 

UE4 Can't get the guardian within the editor.

Level 3
Hi, I'm doing "VR Development with Oculus and Unreal Engine" course on unreal learning. The lesson "Oculus Guardian" I can't seam to get "Is Guardian Configured" to run true on Q2 with link. Is it rift only? oculus subsystem is enabled and so is the guardian within the headset, running 4.26.

Level 2
I too am having this problem when following the VR development with Oculus and Unreal Engine. It should be able to access using the link cable but Haven't found a workaround yet. Have you found out how to fix this problem?

Level 4

Were either of you able to solve this issue?  I'm encountering it as well, and assume it is because of the warning:


LogOnlineIdentity: Warning: Oculus: Failed Oculus login. Not currently logged into Oculus.  Make sure Oculus is running and you are entitled to the app.


I reached out to the instructor who was curious and unable to answer why this happens, and I do not think anyone has solved that.  I also mention this in a No Logged In User thread, so I'd be curious if you guys get the same warning.


Level 2

Is there a way to file bug or tickets for this?

Either the doc or the Guardian Blueprint seems wildly outdated, the doc says

This Blueprint only works with the Oculus Rift, since it retrieves information related to the Oculus Guardian, which is only meaningful when positional tracking is available, i.e. when 6DOF (six degrees of freedom) support is provided by the product. 

Hoping there is a way to get Guardian info for Quest, this is pretty fundamental info for any VR development.

Level 2

I have the same problem. @robert.ooghe.1 I did check that thread you mentionned & solved the online connection issue (thanks for that).

Thanks for that info. So yes, I definitely think people should be reporting that as a bug.  I will on ODH when I get a chance, hopefully if people find this thread and also do so it'll get the right visibility.

Level 3

@robert.ooghe.1 @davidlrm 

I made a ticket on the 7th of march. Just got an email today that the engineering team will look into this.

One interesting discovery.  For the first time yesterday I managed to cook and launch my project to the Quest 2, and running it from *there* I believe I'm accessing it, as I have a debug function that now seems to be working.

Level 2

Same issue here, not working on Link, but worked when Launched at Quest2

Level 3

Just chiming in that OVRManager.boundary.GetConfigured() always returns false when I'm using my Quest with Link in the Unity editor.