Showing results for 
Search instead for 
Did you mean: 

hands not showing up with LocalAvator Unity

Level 3
I'm using LocalAvatar -> AvatarGrabberLeft
Oculus Quest
Unity 2019.1.12f1
Oculus Integration 1.39

I can grab objects but my hands are like invisible.   I'm new to unity Oculus Quest development.   I created a brand new project with just 1 cube so I can grab it.

Initially I can't even grab the objects.  I did Tools -> Remove AndroidManifest.xml and then create Store compatible AndroidManifest.xml.

I tried the AvatarGrab Scene that has built in Oculus cubes and I still can't see my own 2 hands.   I can still grab stuff pretending I have an invisible hand.   Anyone know a fix?


Level 2
It's a different issue from the Android thing. There seems to be a bug in Oculus Intergration 1.39 that causes the hand mesh to disappear. I reverted back to 1.38 and it was fixed.

Level 3
Thanks. 1.38 worked and showed my hands.

Level 3
1.39 works as well.  I need to enter my App ID from in Oculus -> Avatar

Level 2

Blitz64 said:

1.39 works as well.  I need to enter my App ID from in Oculus -> Avatar

This worked for me!  Thanks I have been going crazy trying to find a fix. Care to explain how you figured it out?

Level 2
Hello everyone, after three days working on this I thought to share the sample scene working correctly here. 
What a pain. Insert your app ID and should be working smoothly. 
[In both Platform settings and Avatar settings]

Cheers ! 

Level 3
hey there, after adding the app ID to Avatar and Platfrom settings there are still no hands showing up. Any idea what to do now?

Level 3
In the developer documentation it looked like you don’t have to enter an appID unless you want to use a custom avatar.  Anyone know if this is true?  It would suck if you have to request a new appID every time you wanted to experiment with Oculus in Unity

Level 2
I'm having the same issue with hands not showing up. None of the solutions seems to fix it. Not sure if I'm using 1.41 or 1.38 because I installed via the asset store, but the package manager seems to say 1.38.3 is installed. Not sure why it has to be this much trouble to get hands working on Quest considering how easy it was to get head tracking working, and I'm in total agreement that it would be extremely disappointing if an App id was required just to make a test project with hand tracking (although this hasn't solved the issue for me anyway).

Level 5
Did you try my Example and it didn't work?