cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus store regularly unreachable due to samsung "bugs"

ardje
Level 3
Hello,

I've recently have a lot of issues with the oculus app not being able to reach the oculus store. Probably because oculus is now running on the facebook fully 100% ipv6 compatible cloud.
I've also posted this on:
https://www.reddit.com/r/GearVR/comment ... _problems/

The issue is this: the samsung supports ipv6. Up until the screen goes off. When the screen goes off, the ipv6 remains active, but all ipv6 traffic is filtered at the wireless driver.
When I put my phone into my gear vr, it will have ipv6 configured, but it will not be able to do anything with it because it lost it's router. When the screen goes on again, it will not sollicitate for a router. So you have to wait for the next router advertisement to be able to reach something again.
So basically the oculus store does not work when you are on a network which has ipv6.
The bug is purposely introduced by samsung:
http://developer.samsung.com/forum/boar ... eId=239890
And samsung is the only company actively crippling ipv6:
http://www.gossamer-threads.com/lists/nsp/ipv6/54641
Samsung is the only company that somehow think it's better to block ipv6 due to a misplaced believe that it drains battery. Apple is promoting exactly and rightfully to go ipv6 only, as it is the only sane way to stop broadcast induced battery drain.
Consumer access points are able to convert ipv6 multicast traffic to unicast traffic, while they are not able to do that with ipv4. So a normal ipv6 only wireless network leads to less battery drain.
But due to this a lot of people had to increase the router advertisement to every 15 seconds instead of every hour.

If I look here:
https://www.google.com/intl/en/ipv6/sta ... 6-adoption
the problem should hit most of the us based customers.
It might be this is an exynos build only problem.
So how to fix it:
1) oculus: please nag with samsung to remove that stupid filter.
2) for users: turn off and on wifi to force router sollicitation. Do not turn the screen of. Buy an apple. Oh wait, no VR.

This has implications for more than just the oculus store, but since the user interaction with the gear vr it hits the gear vr user the most: you put your phone with the screen off in the headset, it turns it's screen on, tries to reach oculus and fails.

PS: this is on a note4/exynos , ipv6 was flaky with lollipop and kitkat, but I now know why.
If you have a note4/qualcomm, and still have ipv6 when the screen is off, please reply.
8 REPLIES 8

HomerS66
Level 5
Is that the reason why the iphone 6 has such stellar battery life? [/sarcasm]

Ok nagging aside, i don't have any problems when the screen was off to reach Oculus after inserting into Gear VR.
I do have Note 4, Snapdragon on Kitkat tho but when i tried Lollipop a few months back, i dident have a stable wifi connection and lost it several times.

In the wifi settings do you have the intelligent wifi connection option activated? If yes, turn it off.

cybereality
Level 15
I have escalated this issue to the team.
AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV

cybereality
Level 15
I am not seeing this on my end. Can you give me specific steps I need to take to reproduce the problem?
AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV

ardje
Level 3
"cybereality" wrote:
I am not seeing this on my end. Can you give me specific steps I need to take to reproduce the problem?

The fastest way to check it is this:
1) have ipv6 on your wifi
2) ping to the ipv6 address of your phone, turn the screen off. If the ping replies stop you can go further. To be clear, a ping of the ipv4 address will not stop.
If the ping reply does not stop, I want to know your SoC...
I have the N910C exynos SoC, and since the USA has a 21% penetration of ipv6, it might be the quallcom version does not have this "feature", because you would have been swamped with problem reports.
But I have this "feature" on all my exynos phones. I am actually thingking the problem is that the original wifi chip used did not have full eee compliant support, which means that they should have proxied ipv6 "arps" in the wifi hardware without waking the main processor.

If your ping to the ipv6 address of your phone does stop, you will experience the problem. Just wait a while, the exact numbers I do not know yet. Then put it in the HMD, or just start the oculus store.
If the timing is right, the oculus store is unavailable until the next RA.

ardje
Level 3
"ardje" wrote:
"cybereality" wrote:
I am not seeing this on my end. Can you give me specific steps I need to take to reproduce the problem?

If the timing is right, the oculus store is unavailable until the next RA.

I know the timing now:
The router sends out RA's with it's own local-ipv6 address as gateway. This address has an expire time. It's comparable to the dhcp lease time.
The phone blocks all incoming ipv6 traffic (outgoing still goes through, but the replies are blocked).
If the screen of the phone is turned off longer than the expire of the gateway in the announcement, the moment the screen is turned on, the phone still has valid ipv6 prefixes, and hence believes it should prefer ipv6 over ipv4, but the gateway has expired, so it has no default route.

This makes the oculus store unavailable up until the next unsollicited gateway advertisement.
Also background downloads (with the screen off) are not possible.

So to fix this, oculus has to remove all ipv6 addresses from the dns.
A better fix would be that samsung stopped blocking ipv6 on false grounds (I would love to have a word with the guy that probably didn't even measure it) because more and more enterprise networks are rolling out with ipv6. And instant messaging on samsung does not work with this "feature" as they call it.
But they have a bigger problem than this wifi bug, as knox site blocking can be completely circumvented by using ipv6. Their FAQ reads: if you can reach sites that should have been blocked (by your company knox profile), you should turn off ipv6 for the provider. (t-mobile offers native ipv6 data connections).

emma24xia
Level 2
Has this issue been solved? Anyone tried this yet?

ardje
Level 3
I just found another way to reproduce this problem:
Use a regular computer with a browser to browse to https://web.whatsapp.com/
Make sure your note4 is on an ipv6 enabled network.
Now turn the screen off.
The https://web.whatsapp.com/ will tell you in a minute your phone is offline.

ardje
Level 3
The latest update from samsung to android 6 has removed the ipv6 filter on the wifi. There were a lot of apps on play store suffering from bad reviews due to this negligence.
So anybody with a Samsung without updates to 6 should buy a new phone or accept that a lot of things don't work any more when your ISP enables ipv6 for you. Fortunately that's non of the gear vr capable phones.