cancel
Showing results for 
Search instead for 
Did you mean: 

Unity 5 build on GearVR S6 plays audio but no image

Quixotic7
Level 4
I have a demo I made in Unity 5. This will run fine on my GearVR which is a Note 4 running Android Lollipop 5.1.1. However on my friend's S6, the demo will only play audio and there is no image, the screen just stays black. The Unity Splash screen is visible.

This demo was built using Unity 5.3.0. The S6 is also running Android Lollipop 5.1.1. I also tried having her run a build I made that was basically an empty Unity scene with a just camera, and that build would start with the logo, and then go straight to Oculus Home.

Any ideas as to what could be happening here? Thanks!
5 REPLIES 5

nyohan
Level 2
Just a shot in the dark but did you remember to build a signature file: https://developer.oculus.com/osig/ for your friend's S6?

Quixotic7
Level 4
Yep, definitely used my friends DeviceID to create a signature file. Side question, do you know if you can include multiple signature files in a build, rather than having to make a specific build for each person?

nyohan
Level 2
"Quixotic7" wrote:
Yep, definitely used my friends DeviceID to create a signature file. Side question, do you know if you can include multiple signature files in a build, rather than having to make a specific build for each person?


Yes you can include multiple signature files.

Quixotic7
Level 4
Awesome, thanks for that info!

Quixotic7
Level 4
I finally got it working on her S6 phone by changing the renderer from OpenGL ES3 to OpenGL ES2 and then changing all the shaders to legacy ones. I find it very strange though that my Note 4 has no problem with OpenGL ES3 but the newer S6 phone does.