cancel
Showing results for 
Search instead for 
Did you mean: 

Anybody tried NewRetroArcade?

smsithlord
Level 2
What seems to be a newly formed UE4 design team named Digital Cybercherries released an AMAZING demo yesterday to their site: http://digitalcybercherries.com/

It's an extremely well done 1980's arcade environment with some built-in classic arcade games for you to play all within the VR environment. It is a very very well done VR experience with at least a few hours of entertainment packed into it if you can get into playing the retro games in VR.

Even if you just check it out for a second, it is worth it because DAMN it is immersive. They barely have any Twitter followers at all, so they are asking for help on spreading the word.

BTW, they say they don't have plans to keep working on this demo and it was just a learning experience for their team to get used to UE4 and the Oculus, but what a fun experience it is.

Everything in the arcade is hard-coded so it's not for customization, but because of that everything that it DOES have runs perfectly within the VR environment. The insanely high quality 3D models and art assets and the in-game gameplay are really inspiring for me because I'm working on a VR desktop. NewRetroArcade is a glimpse of what the future might hold for your actual Windows desktop! How exciting is that! But for now, it's just fun as hell to play, so check it out!
48 REPLIES 48

Rashim
Level 3
The new Version is great. the automats have changed a little but are true mames now.

and that brings up a new problem... "insert coin". no key is working.


maybe i have to plug in my gamepad.

NivekTT
Level 2
I download the zip from the Digital Cybercherries website and neither Windows nor 7-zip can open it :cry:

NivekTT
Level 2
Fortunately download #2 from filedropper seems to work, though a slow download!

CountFloyd
Level 3
Small Issue:

The mame games create a new mame folder in the root folder of the drive you've installed newretro (instead of doing this at the location where newretro resides). It seems to store nvstates for every game there. No biggie, just saying...

Anonymous
Not applicable
Does anyone know if its possible to use highscore.dat to store the MAME highscores with NewRetroArcade and their Libretro implementation?

I had a look on the Libretro forums but I couldn't see anything about it.

That would be the icing on the cake for me! 🙂

Thanks in advance!

Anonymous
Not applicable
Managed to get the high scores saving! Result! Was putting the highscore.dat file in the wrong place it needs to go under \NewRetroArcade\Content\Emulators\mame makes sense 🙂

Just got to say if the chaps that built it are reading this, it is one of main things I wanted in VR since I heard about the Rift. Absolutely superb implementation of it. Would love to be able to build my own arcade/cabinets but I am not complaining one bit, insanely good.

Donated the other day, you definitely deserve it. Cheers!

purifier82
Level 4
and that brings up a new problem... "insert coin". no key is working.


Right shift 8-)

Btw has anyone found the 3 easter eggs?
The phone one, present in the old version too, was simple, but I can't turn on the Afterburner II cabinet and find the hidden object, any help is appreciated!
Si vis pacem para bellum

bpm140
Level 2
I can get the sim running with full head tracking in my DK2, but I can't move, either with the keyboard or the gamepad.

Has anyone else worked 1) seen this behavior and 2) worked through it?

Makes me sad as I'm stuck in the hallway. So close...

RiftXdev
Level 3
Did anyone get a fix for this 'can't move from start point'?

I have full headtracking, DK2 but it doesn't recognise any input whatsoever.

Version 2.0 worked, version 3.0 doesn't work
DK1 | DK2 "The question isn't who is going to let me but rather who is going to stop me"