cancel
Showing results for 
Search instead for 
Did you mean: 

Having Problems w/ DK2? [OLD - For Runtime 0.6.0.1]

cybereality
Level 15
THIS INFORMATION IS OLD!!! FOR RUNTIME 0.6.0.1

If you recently received your DK2 and are having problems, please read below.

Before playing any DK2 games, you will need to install the Oculus Run-Time. It is available on the download page:

https://developer.oculus.com/downloads/

After installing the Run-Time, please use the Config Util to setup a profile for your DK2. This will let you set your IPD, height, and other options. You can also try the demo scene (inside the Config Util) to make sure the device is working.

In most cases, choosing "Direct Mode" for the "Oculus Display Mode" will be the easiest setting. I believe it selects this by default, but you can always change this from the Oculus icon in task manager (in the lower-right corner on Windows, right-click and choose "Oculus Display Mode"). In "Direct Mode" Windows will not detect the DK2 as a monitor, but games will still be able to work. The light on the headset will stay solid orange, and the screen black, until you play a DK2 compatible game. Once the game loads the light on the DK2 will become solid blue.

If, for whatever reason, "Direct Mode" is not working for the game you are playing, then you can try "Extended Mode". In "Extended Mode" you will need to set the Windows display to extended desktop (and NOT mirror/clone/duplicate).

You also *MUST* rotate the screen orientation for the DK2 screen. Otherwise your screen will be flipped on it's side. You can change this in the Windows display settings, or in the Nvidia/AMD control panel. In Windows you can right-click the desktop, choose "Screen resolution" and then change the "orientation" options from "landscape" to "portrait". With Nvidia, it's under "Display" -> "Rotate Display".

This may also be a good chance to make sure the DK2 is set to 1920x1080 resolution at 75Hz refresh rate.

Keep in mind that the DK2 will *ONLY* work with games and apps that are specifically coded to support the Rift. Just trying to play any old game with the Rift WILL NOT work. You can find a list of DK2 compatible demos on Oculus Share:

https://share.oculus.com/category/dk2

If you run a non-Rift game, or regular 2D application (including the Windows desktop, web browsers, etc.) then the image will look oddly overlapping or cross-eyed. This is because the Rift uses a single display panel shared between both eyes. So each eye is only seeing one side of the same panel. So if you look at normal 2D content, you will only see half in each eye, which is obviously not comfortable.

If you are experiencing choppy motion in games, also called judder, there may be different solution. The first thing to check is that your computer is fast enough to maintain at least 75fps while playing the game. If you have an older computer, the performance can be an issue. Having Aero (desktop composition) "off" can cause slow fps. Make sure Aero is "on". If you are running multiple monitors, this can also be a source of issues. Making the DK2 the primary display can help. Or you can try setting your monitor to 75Hz refresh (usually this will need to be at a lower resolution like 1280x1024). If you are playing Unity content, make sure it's running in DirectX 11 mode. You can do this by creating a shortcut and adding this to the end of the target command (after a space):

-force-d3d11


If your Rift is not being detected at all by the Config Util, then games will not work. In this case, you may want to double-check all the cables and ports. For example, switch the USB port for the Rift and camera, and also the video port on the GPU. Plugging into a powered USB hub can also help. USB 2.0 may have better support. You can also use new (3rd party) HDMI and USB cables. This cable may work as a replacement for the sync cable:

http://www.monoprice.com/Product?c_id=1 ... 1&format=2

If you are having camera detection or positional tracking issues, then try plugging the sync cable directly from the camera to the headset. You can find the port on the top of the DK2 under the rubber cover. You can also try purchasing the replacement cable above.

In the event you're experiencing crashing in games, or they fail to open, it could be a few things. First, make sure your GPU (graphics card) can support DirectX 11. While older cards may work with some games, it can be a source of issues. Make sure you have the Visual C++ Redistributables installed. You will want both 2010 and 2012 versions in both x86 and x64 flavors.

http://www.microsoft.com/en-us/download ... px?id=5555
http://www.microsoft.com/en-us/download ... x?id=14632
http://www.microsoft.com/en-us/download ... x?id=30679
https://www.microsoft.com/en-us/downloa ... x?id=40784

As of the 0.7 Runtime, you should also install the 2015 files (x86 and x64):

https://www.microsoft.com/en-us/downloa ... x?id=48145

If you are on Windows 7, and receive exception reports when opening the Oculus Config Util, try installing this patch.

http://www.microsoft.com/en-us/download ... x?id=36805

If you have a laptop, please understand that switchable graphics (i.e. Nvidia Optimus) are not well supported. In this case you will have an integrated Intel GPU working along side a more powerful Nvidia or AMD card. Unfortunately, this can be problematic and not recommended. In fact, laptop computers are not recommended at all due to lack of power and various compatibility issues. For the best experience, please use a desktop machine with a dedicated Nvidia or AMD GPU. It's hard to give an exact minimum supported spec, but please try to get a powerful, modern graphics card.

If you are using an AMD GPU, there are currently some compatibility issues with newer drivers. This may manifest has the desktop becoming a black screen, games crashing, etc. It is recommend you revert to Catalyst driver 14.4 until the problems are solved.

If you are on an Nvidia GPU and are getting a strange double-image in each eye, it is a bug with the 347.09 driver. Please update to driver 347.25 (or newer) for better compatibility (make sure to do a clean install and un-check any Nvidia 3D Vision options). Also, if you are using a G-Sync monitor, you may get strange artifacts on the left side of the screen (shifting the Rift image to the right). To work around the problem, please use Direct Mode.

Currently there are conflicts with certain anti-virus and security programs (like ZoneAlarm or Comodo) that may cause the installation of the run-time and drivers to fail. They can also affect running of the service. Unfortunately they may have to be uninstalled, just disabling may not always work.

In addition, USB display hardware or some virtual display/overlay software may cause issues. Known problematic hardware includes DisplayLink, Dell SuperSpeed, and Asus USB displays. Software such as TeamViewer or Origin in-game-overlay may also cause issues.

Finally, if you receive and error that looks something like this "57493-Public TCID:158609 is not responding" it probably means you have the Rift plugged into the wrong video port. This can typically happen when you have multiple GPUs (for example SLI/Crossfire or integrated) and plug the Rift into the wrong video card. Ideally, the Rift should be plugged into the primary video card via HDMI.

For 0.7 specific issues, including supported GPUs and Windows 10 instructions, see here: viewtopic.php?f=34&t=26029

Hopefully this covers the main issues. If you have any common questions, please feel free to reply here. If you have a really strange or unique issue, then creating a new thread in the "Reporting Issues" section may be the better option. Thanks.

// cybereality
AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
473 REPLIES 473

cybereality
Level 15
Extended Mode was dropped since Runtime 0.7. You are probably trying old content, that is no longer supported. Especially if it has a "DirectToRift" mode as that's old and won't work. See here for supported games.

viewtopic.php?f=42&t=25898
AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV

balenski79
Level 2
"cybereality" wrote:
Extended Mode was dropped since Runtime 0.7. You are probably trying old content, that is no longer supported. Especially if it has a "DirectToRift" mode as that's old and won't work. See here for supported games.

viewtopic.php?f=42&t=25898


Back to dinosaur island is on that list and does not work....

sh0ck3r34
Level 2
I can't figure out why my configure utility under tools doesn't have a rift display mode option ??? Just says advanced is all

jzitelli
Level 2
"JonXP" wrote:
I've been using my DK2 with no issues until today. Suddenly the positional tracking is pretty much broken, constantly drifting around when looking straight ahead. If I look directly up or down, the image begins to jump around constantly. Using "show tracker bounds" in the demo scene, I can see the frustrum jumping around the scene when looking straight ahead, sometimes even appearing inverted from where it actually is.

I've verified all the cables are plugged in correctly and no other devices share the same bus (mouse and keyboard are plugged in to the USB2 bus). Verified that the power adapter is plugged in and powering the DK2. I tried plugging the sync cable and the camera directly into the rift (both together and separately), and I've switched around USB ports.

Are there any other steps I can take to fix this issue?


I'll add my experience with a very similar issue - positional tracking would start jumping when looking up or down past maybe +/- 70 degrees, also the position would lurch forward/backward (smoothly, but clearly wrong) in response to even smaller up/down rotations (other movements still seemed to track OK). I confirmed it must be DK2 hardware related (not crazy windows 10 shenanigans) by testing on another computer with the linux 0.5 runtime, the exact same behavior was observed. Switched all the cables, didn't help. My DK2 actually has grown a pretty big crack in the plastic molding on the top-left rounded edge, it's taken some light tumbles, the ports for the cables on the headset also have probably been pulled a bit too much, so I wasn't too surprised that something like this would happen...

I always hope though that when something breaks mechanically, it has a chance of being fixed in a similar manner, so I gently hit the headset from different sides with the butt of my hand, rotating it this way and that, while observing the demo scene to see if anything improved. As best as I can tell, I ended up turning it upside down and I hit the bottom of the headset (so working with gravity), and something must have reconnected, the tracking was fixed! This happened half an hour ago, I don't know how well it will hold up, I'm treating it very gently for now.