Showing results for 
Search instead for 
Did you mean: 

Starship Bridge Demo - Beta

Level 4
This is a VR environmental demo based on the Star Trek Voyager bridge.

Historical Documents are now available for viewing!
Version 0.2 released for testing (don't post to reddit yet please). See update info below.

Press ALT-ENTER to enter fullscreen Rift mode.

You may need to download and install the Microsoft VC++ redistributable here.

I recommend wearing headphones. There are three audio dialog cues you can find and trigger. Press 'e' to fire photon torpedoes.

Made in Unreal Engine 4. It runs at 60fps on my machine with a 760gtx in Oculus Rift mode.
Not sure how it will fare on other hardware.

If someone with a gamepad could test that it works with one I would appreciate it.

Additional screenshots

Download demo. (~114mb)

People have been having trouble getting it from Google Drive so added a Mega download as well.


Update: v0.2 : The Historical Documents are now available for viewing!

1.) Set Windows monitors to "extend desktop" instead of "clone".
2.) Visit using Google Chrome.
3.) Select and play one of the 700+ historical documents.
4.) Launch Bridge Demo v0.2
5.) Geek out.

(NOTE: Please don't post this on Reddit or anywhere else just yet, this update is just intended for testing and finding issues with the video capture and playback code.)


Level 3
Nailed the scale, good work !
It will be nice for the audio coming from the pilot seat if you separated the voices so you could have 3d positioning for the voices, it's simple to do (as they speak one after the other) and will be very effective.

How much "done" do you consider this demo ? More work on it to come ? or are you finished ?

I am sure that, like me you are wishing for emissive photons form emissive materials !
What is the point of simulating correct light physics in UE4 if you can't have the light the way you want !
Damn thoses point and tube lights ! 🙂

Level 2
Great work here! Loving the sense of space and retro vibe it gives. The pulsing light panels are fun to stare at for a while. The demo ran fine for me too, no launch problems.

Level 4
"aschampion" wrote:
Great work, one of the best looking experiences I've had in the rift yet. Alt+enter didn't work for me with focus on or in the window; if anyone else has the same problem it's as easy as opening up the console (tilde), and entering:

stereo on
setres 1280x720 f

Thanks! I think you meant "setres 1280x800"

(I have it set to 1280x800 by default though so should just require "stereo on" if alt+enter isn't working).

I'm curious why it wouldn't though o.O any ideas?

Level 7
Great demo! Really makes you think about all the specialization that each role on the bridge has.

FPS was a solid 60 FPS for me on a GTX680, using "stat FPS". Any way for me to check how much the FPS would be if it wasn't capped at 60?
  • Titans of Space PLUS for Quest is now available on

Level 2
This is just wonderful. Only complaint I have is that the different dialog clips play over each other. It'd be nice if a previous one stopped when a new one was triggered. Other than that though, great job. Would love to have a full Federation starship to explore! 😄

Level 2
Having issue with changing the resolution. Could someone walk me through it again?

I changed the .ini files in Saved>Config>WindowsNoEditor>GameUserSettings but it's still just outputting to 1280x800.

I had the same issue with the RealisticRendering UE4 demo. For some reason the resolution does not change for me.

Otherwise, very awesome demo! I loved it and can't wait to show my friends.

edit: it seems that the resolution is changing, but just not in Rift-mode. When I alt-enter it's pretty evident the resolution is better, but going back to Rift mode you can easily see it's 1280x800.

Any ideas what I'm doing wrong here?

Level 2
Pretty good job! I have good, stable framerates on my Nvidia GTM650. Even my girfried says "Wow no sickness at all" - Normally she has real problems with that.

I do not understand why the others have such problems with a GTM780, it works perfectly for me.

UE4 ftw!

Level 2
"tmek" wrote:

I'm curious why it wouldn't though o.O any ideas?

Not really, didn't get a chance to test much. Two atypical things about my workstation: (1) the rift is the 4th monitor and the other 3 are a mixture of portrait and landscape and (2) bizarro ISO+ANSI layout keyboard. If the former were a problem, I'd still expect it to go fullscreen on some monitor, just not the rift. Since nothing happened on alt+enter, it could be the latter, except UE4 is a AAA engine and an internationalization issue would've been widely reported by now, and I tried with both left & right Alt and AltGr keys. I haven't tried any other UE4 demos to know if it's engine-specific. I wouldn't worry about it, probably just a non-reproducible peculiarity of my setup.

To chip in on performance it ran flawlessly on my 670.

Now you just need to get this guy to give you his models 😉 :

Level 2
I'm a massive Trek fan. Cant wait to give this a go tomorrow.
Got a game in development or a cool piece of VR tech you want to show off? We are looking for demos, trailers and all things VR. Just send us a mail and we would be more than happy to feature it on our site.

Level 2
Hmmm... not sure if it's being hit too hard, but cannot download anymore... says "server error"...
Oculus Hut - A big fat slice of VR A page I made about surfing the virtual reality web! Janus VR Room 45: janus:// YouTube: A little UE4 experience: Virtual Bard