cancel
Showing results for 
Search instead for 
Did you mean: 

Can't specify Windows 10 as minimum required version in ovr-platform-util

jkimura-survios
Level 2
Using the latest version of Oculus Platform Command Line Utility - 1.25.0.571339, if I give --windowsx_min_version "10" as command line argument, I get the following error:
Invalid values:
Argument: windowsx-min-version, Given: 10, Choices: "10", "7SP1", "8.1"
I also noticed there is no longer an option to specify this at all when manually uploading a build through the web site.  I'm guessing this is because the minuim required Windows version is now Windows 10.  https://www.oculus.com/blog/updating-rifts-minimum-and-recommended-spec-os-to-windows-10/

Can we now assume that all builds we upload are locked to minimum Windows 10 and just drop the command line argument when using ovr-platform-util ?
1 REPLY 1

jkimura-survios
Level 2
Yes.  It appears the command line option has changed in the latest version off the tool that I downloaded yesterday.  It was a surprise to me too because the change seems arbitrary and unnecessarily breaks compatibility.  And I guess whoever made the change also didn't update the documentation.

This is what you get when you run the latest version of the tool with the --help option.  Note the change in the option.
ovr-platform-util.exe --help upload-rift-build

Parameters
<snip>
  --windowsx-min-version, --windowsx_min_version, -w  Minimum required Windows version
          [choices: "10", "7SP1", "8.1"] [default: "7SP1"]
I also tried using the -w option, since that has not changed, and get the same result.