Showing results for 
Search instead for 
Did you mean: 

In development game for Oculus Go runs sideloaded via adb but not when installed as preview

Level 3
I have been testing my game on the Oculus Go for several months using adb to sideload it and everything has been working fine. Recently I decided to do a test run of installing an alpha build via the preview channel. The game has the correct entitlement check and passed all the certification checks that are run when you upload a build and, after adding my email to the Users, it was available to install through the Oculus App. The game appeared in my library on the Go with all the proper details.

However, when I launch I initially see my game logo appear and then disappear such that the display is entirely black, but I hear the audio from my game playing including timed audio from one of the game characters. It is as if it is running without any visuals. (I even tried looking around just in case it somehow repositioned my hmd in the game world incorrectly)

I tried removing any vestige of older versions from the Go and then incremented the build number and reinstalled via preview. That produced the same results
I've tried hard resetting my Go and installing clean from the preview channel. Also no go.
Curiously, I tried sideloading a version that was working before and it also exhibited the same problem.

The only way I could get my Oculus Go back to where I could actually see my game playing again was to remove it completely, then remove myself as a user from the Alpha build, then sideload a new build with a new build number.

Has anyone encountered this problem before and if so what did you do to resolve it?

Thank you