cancel
Showing results for 
Search instead for 
Did you mean: 

UE4.23.1 - VRC.PC.Performance.3+5 - 90fps on GTX970 & 30fps on R9 290

GRADGR
Level 4
Hello,

As title says, ive pushed my game to store channel and submitted for review. Got both performance VRCs failed
Ive tested on 2600k with GTX970 and get a stable 90fps . Content reviewer send me an .oda for amd gpu only for previewing the failure.

Does anyone else have this issue? i was forced to make a SERIOUS DOWNGRADE to graphics for the next build. Now am waiting for the reviewer answer.

Is it normal to ask developers make game optimized for r9 290? this is a 2013 card which is pretty much overwhelmed by a GTX970. On their recommended hardware they claim RX480 also. Can i ask for a 480 review? i do not own a r9 290 to test performance, but am guessing this might be either:

- Oculus Software issue
- AMD Drivers 
- UE4.23.1 issue

If someone can help i would be really gratefull!

Thank you!


5 REPLIES 5

GRADGR
Level 4
Just received a new failure after doing really heavy optimization. This time i aksed review team to send both GTX970 and r9 290 .oda . Now on both manufacture gpus framerate seems to be capped at 60+- during whole game...

Anyone maybe can help on this?

My settings are correct,might be missing something?2pzlyvd97li3.png

GRADGR
Level 4
i have changed all FPS settings for above 90, but still is seems there is a cap at 60...

i've notice that :
-when i run the application and i click with mouse on a different windows, focusing on different window, FPS goes 90 as it should.
-also when i enable (rx5700xt) from adrenaline software ENHANCED SYNC fps is at 90.

-this does not happen on a different pc with 2600k&970, it runs at 90 at all times.

PLEASE I NEED HELP

Try going into windows>developer tools>device profiles in ue4 and set the cvars to drop quality on some things like post process. this is too heavy in VR...pic below
Make sure you compile with Development as win64... shipping will NOT work from 4.21 - 4.24

first make sure you have forward shading turned on

Using these settings my app went from 45fps to 90fps
Here are some settings to boost VR frame rates that are essential in VR.
put these in your defultengine.ini in your project config folder

[SystemSettings]

vr.PixelDensity=1

r.SeparateTranslucency=0

r.HZBOcclusion=0

r.MotionBlurQuality=0

r.PostProcessAAQuality=3

r.BloomQuality=1

r.EyeAdaptationQuality=0

r.AmbientOcclusionLevels=0

r.SSR.Quality=1

r.DepthOfFieldQuality=0

r.SceneColorFormat=2

r.TranslucencyVolumeBlur=0

r.TranslucencyLightingVolumeDim=4

r.MaxAnisotropy=8

r.LensFlareQuality=0

r.SceneColorFringeQuality=0

r.FastBlurThreshold=0

r.SSR.MaxRoughness=0.1

r.rhicmdbypass=0

sg.EffectsQuality=2

sg.PostProcessQuality=0

make sure scalability options are set to low on everything except antialiasing. set that to high

set project to scalable 2d and 3d
and use mobile/tablet not pc etc when set to pc it can fail
in 4.21+ 

ALSO THE ISSUE IS 4.23....... It will always have issues with frame rate. try updating to 4.24 and keep using the depreciated input bindings because 4.24 touch bindings are broken atm.

7vjzcehtwfq5.png

GRADGR
Level 4
hey mate! sorry for the delayed answer! The issue was 4.23.1 , i compiled github 4.23.0 and everything worked fine 🙂

gmoney0723
Level 2
What's greater the Ryzen 5 1500X or the Ryzen 5 2500U?