cancel
Showing results for 
Search instead for 
Did you mean: 

ovr-platform-util.exe fails with error "A server error occurred. The request will be retried."

j-lc
Level 3
Hi,

For the past couple of days, I've been unable to upload builds to the Oculus backend using ovr-platform-util.

The following stages succeed:

- Starting upload for app: xxx
- Finding files...
- Validating package...
- Deduplicating segments:
- Submitting segments:

But the last stage "Submitting upload..." loops on the following error: "A server error occurred. The request will be retried."

I'm using ovr-platform-util in version 1.38.0.000001

Is there something wrong on the server side?

Thanks,
Julien
16 REPLIES 16

solaris.nite
Level 4

@mouse_bear Thank you for your attention to this issue.

 

Unfortunately, this issue has been plaguing us for weeks and still has not been fixed. The upload succeeds randomly every ~3 attempts. Our upload process occurs on a server build agent and it was working perfectly until a few weeks ago--now it fails a majority of the time.

A server error occurred. The request will be retried.

 

This issue has been consistently putting a wrench in our development process and has been wasting a lot of developer time and has forced us to delay some releases. We upload multiple builds every day and release every week so this issue greatly impacts our team. Uploading builds is fundamental and I humbly request for this bug to be prioritized.

Thanks in advance 🙂

benmcnelly
Level 3

Still getting this on the command line tool and the utility. Also there is a message whenever using the command line version:

***************************************************************
* Your copy of Oculus Platform Command Line Utility is old.   *
* Version 1.67.0.000001 has been released on Thu Oct 07 2021. *
* Please use the following command to update it:              *
*   > ovr-platform-util.exe self-update                       *
***************************************************************

 

But that in fact IS the version of the utility that we are running. So, the utility is detecting itself as an outdated version, perhaps the latest build didn't have a cert or version bump it needed?

PS C:\Users\Specter\AppData\Roaming\odh> .\ovr-platform-util.exe
Oculus Platform Command Line Utility - 1.67.0.000001

Does anyone have an old installer from mid October maybe?

 

As of right now we are at a complete stand still as there is no other way to upload.

Just to clarify, same issue as others in this thread:

***************************************************************
* Your copy of Oculus Platform Command Line Utility is old.   *
* Version 1.67.0.000001 has been released on Thu Oct 07 2021. *
* Please use the following command to update it:              *
*   > ovr-platform-util.exe self-update                       *
***************************************************************

Validating build...
A server error occurred. The request will be retried.
A network error occurred. The request will be retried.

DaVad3rInHale
Level 3

Same here! Can't upload anything even though I just busted my hump to get the update finished this week. What's the issue?

Jimboww
Level 2

I got the same error when I wanted to upload my rift app through the Oculus Developer HUB.

Jimbow84_1-1652393025590.png

(Strange the uploading of the Quest app works right away with Oculus Developer HUB) 
However, I found a hint on the oculus dashboard on the web about that how can use the command line tool manually. And it works.

Jimbow84_0-1652391688326.png

Of course, the app-id and app-secret params are essential. You can obtain them on the oculus dashboard of your application.
(Probably, the Oculus Developer HUB uses the 'ovr-platform-util.exe' wrongly or in the old way to upload the rift application.)
I hope it helps anyone who has a similar problem.

 

jorrit-de-vries
Level 3

The actual error message in the hub or terminal is not really clear; I got this error as `ovr-platform-util` tried to upload a hidden file. A better message is in the actual log file of the upload run of which the path is written at the top of the output.

lufinkey
Level 4

Am somehow getting this error again over and over in the CLI too. Copied the CLI command exactly from the website. Never had this issue uploading previous builds