cancel
Showing results for 
Search instead for 
Did you mean: 

3090 ti - Oculus Rift S Display Port Issue

W3SL3YP1P3S
Level 3

Hello,

I recently upgraded my 2080ti SLI to a 3090 ti. Everything has been great, most of all was just happy to no longer have to tinker with profile settings to get the SLI to work for some games.

Then I went and opened up the Oculus software to try out some VR games with my Rift S and got a warning about display port not connected. This was a little troubling since VR worked perfectly fine with the 2080 ti's.

So I did all the standard thing like reconnecting the USB and display port cable at both ends, trying different display ports on the 3090 ti that are indeed working when monitors are plugged into them. I used DDU to remove all the display drivers and then re-installed them with clean install and same issue. Did that again but with also re-installing the Oculus software and drivers clean but issue persists.

So i start wondering if the headset is broken so I plug it into another PC I have with a EVGA GTX 980 and headset works perfectly fine. So I once again use DDU to uninstall all display drivers on my main PC, remove the 3090 ti card, install one 2080 ti card and install it's drivers and Rift S works fine with the 2080 ti on that PC with nothing else changed except the card and drivers.

So at this point it appears there must be a compatibility issue with the 3090 ti and Rift S detecting display port. So I take to Reddit, Nvidia, Oculus, Guru3d forums and cannot find anyone using this config either working or with issue. I do however find a lot of people having a similar display port issue with the 3090 ti and the HP Reverb G2.

So I open support tickets with Oculus and Nvidia. I have gone through all their troubleshooting steps and submitted my logs to them but they are both stumped at the moment. Oculus was kinda like, most likely this will be resolved in a driver update or 2 from us or NVIDIA. NVIDIA has sent me to 2nd level support but haven't heard anything back yet.

Just wanted to post here to see if anyone has the same config either working or with the same issue. If this is an issue with Oculus headsets like it is for the HP Reverb G2, want to make sure they are aware and looking into it as well.

41 REPLIES 41

Sure! I also read that an active USB 3 hub might help. Tried that today and also nothing. After everything a incompatibility issue between the two seems most likely. The Rift S works with the old card, and the DP Ports from the 3090ti are also working just fine with my Monitor.

The G2 should arrive on Thursday, I will let you know.

W3SL3YP1P3S
Level 3

Yeah, from my reading it seems people have only been getting the Reverb G2 working with the 3090 ti if they swapped the cable for an older Gen 1 cable. Sounds like Nvidia need to put its head together with the VR manufacturers and figure out how to make the driver compatible with these headsets

Merlin919
Level 3

Just set up the Reverb. No joy. BUT, there is a new Nvidia driver 512.77, that has the issue with Rift/Pimax in the release notes. I did not check the older release notes if it was mentioned there, but I hope it will be fixed with the next driver update. I can't believe that it's that difficult to fix.

W3SL3YP1P3S
Level 3

So the 512.77 Release notes had me excited. Unfortunately still not joy. 

 

I installed driver and tried Oculus but still not detecting Display Port, rebooted, same.

 

I used the Nvidia driver cleanup tool support had me use before and then did a clean install of 512.77, rebooted. Still Display Port not detecting.

 

In Oculus I toggled back and forth between Public Test and Standard to try both software versions but neither detect Rift S Display Port.

 

Tried plugging in different display ports and disconnecting Rift at headset end.

 

Doesn't appear the driver has fixed the issue with the Rift S. They mention the Pimax too in the Release notes so curious if anything changed for them or HP Reverb G2 owners.

What I wanted to say was, they acknowledged the problems with the Rift S and Pimax, it's not solved yet. Sorry if the previous post was misleading.

Oh yeah I figured that was what you were saying. Figured I would be proactive and see if any change had occurred.

Thanks for the heads up on the driver though, was your post that made me notice it. 🙂

Thanks for the update. I also tried the 512.77 Nvidia driver and having the same unsuccessful results.

 

Curious to know if you are going to try getting your hands on a Gen 1 cable for the G2 and see if that works? Seems that all other options are exhausted at this point and we just have to wait for further driver updates.

No, if it's not fixed at the end of next week I'll probably switch cards and go for the 3090. Coming from the 1080ti it's a huge step anyway and a friend of mine had problems with the original Reverb cable, so that's too much hassle.

viking85
Level 3

NVidia knows its an issue and has it posted as an open item. Hopefully this means its being worked on from their side as well. 

 

unknown.png

berilojr
Level 2

Does anyone have this problem fixed, mine still the same, I do have both reverb v2 and rift S no luck on both, I'm back using my cv1 but it is very frustrating... does anyone know if have an fix for this to the Rift S?