cancel
Showing results for 
Search instead for 
Did you mean: 

Air Link gone crazy

Baliszoft
Level 4

Sadly i cannot use air link anymore on my quest 2. 😞

When i connect to the PC, the "white loader" it is very slow, image makes me dizzy, controllers are slow reacting hardly can select QUIT air link. It was working perfectly before (!!!), so it is not my PC being low spec (i9-9900k-32Gb, RTX3080ti, Asus gaming Wifi6 router on 1gbps ethernet to PC, nothing else on the wifi6 network).
The oculus upgraded itself to v39, but i dont remember if problem began after that or not (probably). I also installed the latest nvidia drivers today, but no remedy. It works with the USB cable though.

Bought virtual desktop yesterday which also works fine, but i would prefer air link (VD seems to have higher overhead and its frame rate doubler "spacewarp" is a joke).

So something went wrong, i cant get airlink to work properly :(. Did use it in the past months without any problems and now its a nightmare.

20 REPLIES 20

OculusSupport
Community Manager
Community Manager

Hey Baliszoft!  We'd love to help out to get your Air Link functionality to work properly again! We have some clarifying questions to ask to see if we can spot the culprit of the issue, please make sure of the following:

  • Do you have any unnecessary software or applications open while trying to connect to Air Link? If so, please limit the amount of open software to the ones required for playing PCVR.
  • Are you receiving any errors, or is it just poor performance? This will help us narrow down our possible solutions! 
  • Are you enrolled in the public test channel? The PTC has been know to cause issue with Air Link, and we recommend opting out to potentially fix this issue.

We do have some steps we recommend to hopefully get your Air Link to function properly, please complete the following: 

  • When trying to connect your headset to Air Link and you get this issue, please do the following:
    • Restart PC, reboot Quest 2, and restart router.
  • Please repair your Oculus PC application:
    1. Go to www.oculus.com/setup and click Download Oculus Rift software.
    2. Select Repair.
      • If Windows asks you if you’re sure you want to open this file, click Yes.
      • If Windows Defender prompts Windows protected your PC, click More info and then click Run anyway.
      • If your antivirus software restricts the file from opening, temporarily disable your AV and continue.
      • Please remember to re-enable your antivirus software once you've completed the repair.
    3. Allow the repair process to run, download and install.
    4. Launch the Oculus app.
  • Please look for updates to the Oculus drivers:
    1. Close the Oculus app.
    2. Press the Windows key + R on your keyboard to open the Run command.
    3. Enter C:\Program Files\Oculus\Support\oculus-drivers.
    4. Open oculus-driver.
    5. Open the Oculus app and then try to connect your headset again.
  • Reset your graphics preferences:
    1. Open the Oculus app on your Computer.
    2. Click Devices on the left side of the app.
    3. Click Quest and Touch.
    4. Click Graphics Preferences.
    5. Click Reset to default.
    6. Click Save and Restart

We hope this helps! IF not, please don't hesitate to reach back out and we can point you in the right direction! Thanks for your patience with us while we work towards getting a solution for the performance issues you are having with Air Link! 

rasimf1
Level 3

Hey buddy, have you managed to fix the problem? I'm facing the same issues, after v39 update

Baliszoft
Level 4

Sadly none of the above tips helped.
No other software running (fresh windows start), no firewall, no PTC, no errors (error messages) of any kind.
This is how it looks like:
https://www.youtube.com/shorts/NWDj8KiPOGk

Video is on default graphics preferences (72Hz, 1.0x resolution).
No bandwidth problems on the wifi (virtual desktop works, i just dont like it).

KatGod101
Level 3

This honestly might be a V39 problem. This issue is present on the Quest 1 as well but instead of it being a second or two of delay, its 5-7 seconds delayed. Image looks clear, but the drawback is delay. Hopefully this gets fixed sooner or later, as it seems it might be a user to user thing since there are a few people who I know who use airlink as well but have no present problems. 

I hope your problem gets fixed somehow!

Was actually having the same issue the other day which was alleviated by switching to a wired connection instead of wifi. In my experience, the interface was sluggish and reacted slowly, sometimes looking around would cause screen tear so I had to use virtual desktop for that time. Once I switched to an ethernet cable though, everything was running smoothly. My experiences seem to tell me that even though you may have good bandwidth, there's still issues with airlink unless you're wired, which is probably because the quest tries to render at full resolution instead of adjusting the resolution based on connection like virtual desktop.

Take your destiny into your own hands. Sand cannot keep a shape by itself, but add water and it becomes malleable. Fate can be such, if you add the right element.

Baliszoft
Level 4

Yes, image is clear here, too (can see the anti aliasing work (flicker at the max screen refresh rate) just like before) but the delay is quite challenging ;).

I would definitely try a wired connection to see if anything changes. The delay should be fixed once you do but let us know your findings

Take your destiny into your own hands. Sand cannot keep a shape by itself, but add water and it becomes malleable. Fate can be such, if you add the right element.

Wired (USB) connection works perfectly.
Air Link was working perfectly too (when i last played with it).

Yeah, Im having similar issue, and i remember 100% like around 1 month it was running perfectly (same pc with 3080ti, same wifi6 router).  200mbps fixed, not a single problem. Now its lagging with black screens on the sides, cant track the controllers, everything is messed up. It happens to me cinside the game, constantly during the level loading, and then during the gameplay itself as well very often. With cable connection everything runs perfectly smoooth. And I said, it wasnt like this before, i guess it has something to do with v39 firmware.