Showing results for 
Search instead for 
Did you mean: 

Air Link

Level 4

Hi all! I am using the Oculus Quest 2 and am trying to get Air Link to work. I have it on the PC App and the Quest. Whenever I connect to my PC, the Oculus app shows it has connected, but the Quest had 3 dots and then goes back to the home screen (normal Quest home screen). My PC (while the 3 dots are up) gets a notification about 2-4 times saying 'We can't find your headset.' I also get a notification saying, 'Oculus isn't working properly.' All in this time, the Oculus app still says the Quest is connected to the PC. What should I do? Also yes, the, 'We can't find your headset.' DOES happen while this is going on. Same for, 'Oculus Link has stopped working.'


Level 2

Same it is just not working.I tried uninstalling it and restarting my computer and it still won’t working.

Level 2

Same here and I have also seen this exact issue on multiple posts now with no resolution so far. 

Level 7

It might help if you post more info about your setup like your pc, and network setup. Is your pc using ethernet, 5ghz, 2.4ghz(Don't try that). Have you made any changes in the oculusdebug app. Things like that.

No, I haven't made any changes. Here's a link on reddit where all the info is (yes, this is my thread), also where people have been trying to help.

You have a 750ti. 

It says it will still work. Also yes thank you for noticing that I'm broke.

You and me both. I live in the ghetto with rodent problems. 🤣

Oof. I tried the fix with the drivers but to no avail.

Level 3

I have the same problem. My PC is an Asus G14 with AMD 4800HS and 1660ti.

Router is a Tplink AX90 connected to my laptop wired via 2.5GbE.


I've noticed alot of people reporting this problem on Reddit, and many reporting have an AMD CPU.


I've tried the following with no success:

-resetting experimental settings

- updating to the latest Nvida drivers

- disabling screen overlay in Geforce Experience

- uninstalling Geforce Experience

- disabling the Windows firewall

- reinstalling the Oculus PC app.

- setting encoding resolution to 1800 in the Oculus debug tool (


Virtual Desktop works perfectly, so it's not a networking issue.