cancel
Showing results for 
Search instead for 
Did you mean: 

Air Link

AddictiveJokes1
Level 4

Hi all! I am using the Oculus Quest 2 and am trying to get Air Link to work. I have it on the PC App and the Quest. Whenever I connect to my PC, the Oculus app shows it has connected, but the Quest had 3 dots and then goes back to the home screen (normal Quest home screen). My PC (while the 3 dots are up) gets a notification about 2-4 times saying 'We can't find your headset.' I also get a notification saying, 'Oculus isn't working properly.' All in this time, the Oculus app still says the Quest is connected to the PC. What should I do? Also yes, the, 'We can't find your headset.' DOES happen while this is going on. Same for, 'Oculus Link has stopped working.'

34 REPLIES 34

Any fix so far?

Sumerset
Level 3

Same problem! Regular Link works fine, as well as VD.
CPU: AMD FX-8350
GPU: GTX 770
Router: Xiaomi Mi Wi-Fi Router 4A (5g)

SHILLIAM
Level 3

Hey guys I got Air Link working yesterday, forgot to post here. My issue was with Oculus Link in general, not just Air Link, so if youre only having problems with Air Link this probably won't work for you.

 

The problem turned out to be Nvidia drivers, as I thought. I had to roll back to driver 461.92 since each one after that would crash Link. If you want to do the same go here, select your specs based on the options they give, and choose the compatible driver to download.

 

Do this at your own discretion, since rolling back drivers can affect performance and stability with other games (especially whatever games you'll want to play with Air Link). This is only a temporary solution until we get a driver that doesn't break Link for us. 

Tried that, didn't work. Thanks anyway!


@AddictiveJokes1 wrote:

Tried that, didn't work. Thanks anyway!


Have you confirmed whether or not the issue with only Air Link, or Oculus Link too?

I can't use oculus link as the ports on my pc don't work, but I don't have this issue with virtual desktop. When I use a laptop to connect to SideQuest however, (with a cable) it works.

Any ideas?

BluesMeister
Level 2

Ryzen 5 1600, RX580, AC Network, PC hardwired over 1Gb here.

 

Every time you try to connect, it just disconnects. Several Win10 popups about not being able to find the device. But at times the headset and controls show green on the PC. 


@AddictiveJokes1 wrote:

Any ideas?


Couldnt tell honestly. I do think your problem is Link related though, not just Air Link, since it sounds very similar to the problem I was having. My only guess is it's something else software related on your PC that is not compatible with Link and is causing it to crash. 

aphasiac
Level 3

I opened a support ticket for the issue. Here's what they told me:

 

After reviewing the log files, I see that there are some updates needed which can cause the issue you are experiencing. Please have the following updated:

 

1. Update your graphics card drivers by following the direct link to the manufacturers website Click here for the NVIDIA driver update page here: https://www.nvidia.com/Download/Find.aspx 

2. I recommend that you enable your PTC. For steps on how to enable, please click the link https://support.oculus.com/200468603765391/.

3. Ensure that Oculus is added to the white list of of your anti-virus program or temporarily disable it. You can check https://support.oculus.com/225459294538101/ for the steps.

4. If you are using Oculus Tray Tool or other third party software that can make modifications to graphics or settings, please uninstall for troubleshooting purposes as these programs can cause conflicts that effect performance and display.

5. Please disconnect any extra Display devices connected to the PC leaving only the product hardware, mouse, keyboard and one primary monitor

6. The next thing that I would like to ask is to check if Game Mode is enabled on your system. Follow the steps below: Open the Windows Settings menu Click on Gaming Click Game Mode Toggle Game Mode off if it’s turned on