Showing results for 
Search instead for 
Did you mean: 

Air Link

Level 4

Hi all! I am using the Oculus Quest 2 and am trying to get Air Link to work. I have it on the PC App and the Quest. Whenever I connect to my PC, the Oculus app shows it has connected, but the Quest had 3 dots and then goes back to the home screen (normal Quest home screen). My PC (while the 3 dots are up) gets a notification about 2-4 times saying 'We can't find your headset.' I also get a notification saying, 'Oculus isn't working properly.' All in this time, the Oculus app still says the Quest is connected to the PC. What should I do? Also yes, the, 'We can't find your headset.' DOES happen while this is going on. Same for, 'Oculus Link has stopped working.'



I'm going to be trying it on my brothers PC soon, and his is much more powerful then mine. Lets keep our fingers crossed.

I tried everything on this list, except updating my drivers. They are currently updating now.

went through all steps. still nothing

Level 5

I actually experience that when I switch between Air Link and wired Oculus Link. What I do is use the Oculus Debug Tool to stop and start the Oculus services. Also, it is important to restore your Debug Tool settings to default since your custom Oculus Link settings may not work with Air Link.

Level 4

I have similar. In my case though, it connects just fine. When I choose Launch, I get the 3 dots and after about 20 seconds back to Q2 Home screen. It also briefly show as disconnected when thi happens. After about 5 seconds it connects again. However, if I reboot then all works well for a while. If it has been a while between sessions the problem returns. I saw another post about not working while screen is locked, I will check that out tonight to see if that is what is going on. After a reboot the screen would be unlocked for a bit and it always Launches fine after a reboot.

Level 3

Hi all,

Good news, I got Air Link working. First I tried all the advise from Oculus support - after each step, I tried Air Link again but each time it still failed. Then I tried the following:

1. Open Nvidia Control Panel.

2. Go to Manage 3D Settings > Global Settings.

3. Under "Preferred Graphics processor", select "Auto-Select" (mine was set to "Integrated Graphics" to help laptop battery life). 

4. Click Apply.


That fixed the issue instantly - clearly something from Oculus was trying to launch on my Intel integrated GPU. Had a great game of Alyx, runs much better than on Virtual Desktop. 


Can someone in the thread try this, and see if it helps? Note: It might also help to change it from "Auto-select" to "High-performance NVIDIA processor".

Unfortunately, mine is already set that way. Always has been. Mine works, but if it has been more than an hour or so since last use I have to reboot the PC to get it to launch again.

Level 3

I have exact same problem. Basic Air Link Connection is present, but when I click on Launch it goes to three dots on a black screen, sits there for a few seconds, then gets back to main Quest lobby. PC app intermittently loses connection, then restores it back.


I even tired to read some debug logs around the moment of crash:


28/04 13:11:03.019 {INFO} [PluginManager] Switching active headset from OVRDefault : <no headset serial yet> to Oculus Link : 1wmhh834zq1094
28/04 13:11:03.019 {INFO} [PluginManager] Active headset is now Oculus Link : 1wmhh834zq1094


28/04 13:11:03.148 {!ERROR!} [xrstreaming] OculusVadSharedMemoryProducer::initialize: capture could not open mutex: .
28/04 13:11:03.148 {!ERROR!} [Kernel:Error] OVR Error:
Code: -6100 -- ovrError_XRStreamingGeneralIssue
Description: OculusVadSharedMemoryProducer::initialize: capture could not open mutex: .
OVRTime: 76725.880531
Time: 2021-04-28 13:11:03 [148:469:700]



I think my laptop does not have enough video memory to run it (Asus TUF Gaming A15, w/ Nvidia RTX 2060 6GB).

Level 4

In my case it turned out to be because the desktop was locked. If I unlock it before trying to launch, then it works. If locked when I launch, the just the 3 dots and back to Quest Home screen.