cancel
Showing results for 
Search instead for 
Did you mean: 

Airlink stopped working with my usb to lan adapter.

SamaritanMan
Level 3

Hi everybody,

I have an Asus Rog Zephyrus 2021 that has 2 type-c ports, one of wich i used so far to connect an usb to lan adapter for a router to play pcvr games using my Quest 2.

Some days ago, airlink started disconnecting after 1-2 seconds after connection and i hear the windows usb disconnection sound, when this happens.

I tryed connecting the usb to lan adapter to the other type-c port and anything worked perfectly.

So it is an issue with that specific type-c port in windows 10, for sure.

Now i can play however in pcvr, using the other type-c port, but i wish to solve this issue, because the related usb port, is more comfortable for my laptop positioning on my desk.
Can you give me some advice?

I tryed uninstalling all the usb components in device manager and reinstalled them, but the issue is not fixed. 

2 REPLIES 2

OculusSupport
Oculus Community Manager
Oculus Community Manager

Hey there SamaritanMan! We'll do our absolute best to get you back into the game again and get your Oculus experience back up to 100%! Below I've outlined some troubleshooting steps you could try to alleviate any potential link issues.


Are there any updates to Windows/GPU/USB?

Sometimes there may be outdated drivers or pending updates that could interfere with the Link and its performance. I've included a guide on how to check for updates to your drivers here! The article is titled for Rift/Rift S but is applicable to Quest/Quest 2 as well.

For Windows, there's an article on how to check for updates here!

If updates are found for either, make sure you restart your PC once they are complete, then try to use Link again.


Game Mode may conflict with some VR applications.

In Windows 10, there is a feature called "Game Mode". Game Mode appears to reduce or eliminate background processes, and focuses performance on the active game. This could interfere with the Oculus software, as it needs multiple processes running simultaneously to function properly. Try disabling Game Mode, then attempt using Link again.

Open the Windows Settings menu
Click on Gaming
Click Game Mode
Toggle Game Mode off

Conflict with settings in the Oculus app.

Sometimes you may be able to alleviate the issue by resetting the graphic preferences to default. I've included a support article on how to do this here!


Conflicting software.

There are a few pieces of software known to cause issues with Oculus processes; ASUS AI Suite or ASUS Ai Suite 3. This software is an all-in-one application that allows users to make modifications to motherboard components such as CPU, USB, Wi-Fi, LAN and more. When troubleshooting any issues that use devices affected by this software, it’s recommended to uninstall ASUS AI Suite, if installed, and test to see if the issue remains or disappears. Your PC may need to be restarted after removing this software.

If present, also uninstall Oculus Tray Tools, as it contains settings for resolution, super sampling, etc. that can impact performance.


Other Options.

Below are a few other options you could try if none of the above options work.

Try alternate USB 3.0 ports, after removing any non-Oculus USB devices, to help account for USB bandwidth and issues with specific ports. Stripping the connections to a minimum may be helpful; connect only the headset, as well as your mouse and keyboard.

Attempt to enroll in, or opt out of, the Public Test Channel using steps from the article here.

Repair the oculus PC Application using these steps. Once complete, restart the PC and attempt to enable Link again.


Submit a Support Ticket.

Collect Oculus Diagnostic Logs using these steps and submit them in a support ticket so that we may look over them and confirm any conflicting software, PC/System updates and inconsistencies.


If you have any other questions or concerns, we'd be happy to help! Cheers!

SamaritanMan
Level 3

I solved the issue, enabling the Windows 10 Defender monitoring on the usb-type-c involved port.

The Defender check was oddly disabled.

Thank you however for your support.