Showing results for 
Search instead for 
Did you mean: 

Anker Charging Dock for Quest 2: Left Controller Constantly Blinking Amber

I've seen this question posted a bunch of times, but I've tried all the answers posted in previous iterations and still have the problem, so posting here in hopes of finding new ideas.

Any help would be much appreciated. 



Anker charging dock for Quest 2, left controller charging light constantly blinks amber. When I take the battery out and re-seat it and put the cover back on, it sometimes will work for a few minutes but then starts blinking again.  It's a total pain.  Anker has replaced this unit with a new one (including the controller battery doors, batteries, plug, wire, everything was replaced) and it still does this. The only common denominator is the controller itself but I don't see how that could be the source of the issue since the charging circuit is between the dock and the battery. The controller itself works fine otherwise.



1. Yes, I know the battery has metal contact points that need to connect with the tangs on the battery door.  I make sure they're oriented correctly before installing the door.

2. I tried switching the batteries; the light blinks no matter which battery is installed, and the other controller charges fine no matter which battery it has.

3. As stated above, Anker has replaced this with a whole new unit, including the battery doors, batteries, and wire/plug. The only thing that hasn't been replaced is the controller itself.

4. Made sure the power plug is seated correctly and not loose.

5. Tried plugging the dock into different wall outlets.

6. As stated above, taking the battery out or spinning it in place, then re-seating it, will work for a couple minutes (at best) before the blinking starts again. Each time I've tried this I've made 100% sure the battery is oriented correctly so the metal strips are in contact with the tangs on the door, and that the door seats correctly when I put it back on.


Community Manager
Community Manager

Hey there! Thank you for reaching out. We see your concern here. This definitely shouldn't be the case. The controllers should be charging regularly. Good initiative on taking the time to troubleshoot! We recommend you submit a support ticket, so one of our specialists can go over your next options with you! 

Thanks, but when I contacted Meta about this they said "this is an Anker product; talk to them", and when I talked to Anker they ran thru their troubleshooting steps and ended up just sending me another defective unit. So I'm here looking to see if anyone has been able to figure out a solution on their own that I haven't already tried.


Unless you think it's possible that the controller itself is the source of the issue and there's something I can do to troubleshoot that?