cancel
Showing results for 
Search instead for 
Did you mean: 

Anyone have a fix for this?

Thecowgoesm00
Level 2

Hello, I am new to VR and having some trouble with my headset. In particular, it's not "charging"(Or the charge isn't dying slower than it would if it had been unplugged.)
-There is talk about it only charging to 80% but it isn't even doing that.
 
My pc meets the requirement specs for being able to play steam VR with the oculus rift official C to C cable (Which is what I own)

The problem is my Quest 2 isn't "slowly dying" when I'm playing it. It dies the same amount of time as if it wasn't plugged in, which is 2-3 hours.
I have tried using the oculus charging cable that comes with the oculus through my pc to see if I can get any charge when I'm not charging it, but it doesn't charge either.

I tried a reboot (Not a full restore). Although I'm not too sure if I did it correctly. I held it down for 30 seconds and it beeped a few times as if it was turning off and on.

I also tried checking how much power is going through the usb ports, (Disabling the power save option on whichever ones had it because it didn't say which one was my C port. It also didn't say if one was powered or not and how much power it was allowed.)

I've called the retailer where I bought it and they said it might be a battery issue inside my headset.
The cable does allow me to play on Steam VR just fine, but it's not giving a charge enough for me to play for a decent amount of time. 
Any advice or anything else I could try? I will probably try to switch out the cable and worst case scenario my headset. I would like more advice before I do this though. Any help is appreciated. I hope I got the right location. Sorry if I didn't.

0 REPLIES 0