cancel
Showing results for 
Search instead for 
Did you mean: 

Apps won't install

MintMass
Level 2

Hello, a few weeks ago I tried to re-install Walking Dead: Saints and Sinners to my Oculus 1. Once all the gigabytes required were installed the game was titled as "installing, this may take a few minutes". The app has been in that state for months now and I cant install any of my apps because of it. If anyone has any idea what to do I would appreciate all help. (I have tried restarting my Oculus)

1 REPLY 1

OculusSupport
Community Manager
Community Manager

Hey there MintMass! Installation processes should be quick and easy and get you into new VR experiences to enjoy, so it's disheartening to see that you can't luxuriate in new experiences. We'd recommend ensuring that you've enabled your cloud backup feature for the next step. After you've enabled cloud back up on your headset, you will perform a factory reset on your device. A factory reset will remove all data present on your device, but the cloud backup feature you enabled previously will allow you to access your game progress once you've logged back into your account on your headset!