cancel
Showing results for 
Search instead for 
Did you mean: 

Bad Airlink bitrate for AMD Radeon graphics

ashenone23
Level 2

With an AMD graphic card, I set Airlink's constant bitrate as 100 Mbps.

On the previous quest 2 and Airlink software builds, the oculus process network usage was like 120 Mbps in Windows task manager.

But now, it is 75 Mbps at maximum (as checked in Windows task manager) even though it is set to 100 Mbps.

Oculus debug tool also couldn't fix it.

It's not only for me but also for all other AMD graphics users.

I think something is broken in the latest build. Plz fix it.

 

One thing more, Oculus PC software is not supporting the HEVC codec for AMD graphics users. (for a long time!)

Plz update it.

1 ACCEPTED SOLUTION

Accepted Solutions

Is not oculus fault, the amd drivers suck ass and the latest version has broken the encoder for all third party apps that uses it. I'm still using the 21.10.2 that works with everything.

View solution in original post

10 REPLIES 10

falita7
Level 3

I saw the same thing, it was 150mbps but after the updates when i tried again i saw it limited to 65-75mbps and h264 instead of h265 that amd is perfectly capable of. I ditched airlink because the quality is just awfull at this point with amd.

 

Using virtual desktop for now and getting 150mbps no problem.

Thx for your reply!

I also have Virtual Desktop, and it works perfectly.

However, with VD, I cannot use OpenXR, which is awesome.

I recently found out that earlier driver versions of Radeon Software are okay.

(Not okay with 22.5.1 release)

Maybe it's Radeon's problem, or maybe not. Not sure.

Nytevizion
Level 4

Same here. My Q2 and 6900xt used to work very well and looked good with Airlink. Averaged 125-135 Megabit during play. Now it tops out at 65 Megabit at 80Hz and looks pretty bad. It fluctuates depending on the refresh rate but it's capped for sure. At 72hz it's around 55 max. Tried two different routers with the same exact results. I posted about this a while back. Dealt with Metaoculusbook and got nowhere. It happened under Win10. I recently switched to WIN 11 hoping it might change something. It didn't. They said they couldn't help me because 11 isn't supported. AMD usability has been sabotaged.

Z690 Gaming X-12700K-6900XT-16GB-3900MHz-DDR4-AIO MSI MAG Liquid

The only problem with VD is that you can't reduce the viewport size and gain a ton of free performance. Otherwise it would be fine. I wish they would address that.

Z690 Gaming X-12700K-6900XT-16GB-3900MHz-DDR4-AIO MSI MAG Liquid

Is not oculus fault, the amd drivers suck ass and the latest version has broken the encoder for all third party apps that uses it. I'm still using the 21.10.2 that works with everything.

Nytevizion
Level 4

THANK YOU!

I didn't know when it happened, tried previous AMD drivers but didn't go back that far.

This IS the answer. Now to make noise.

Untitled-1.png

Z690 Gaming X-12700K-6900XT-16GB-3900MHz-DDR4-AIO MSI MAG Liquid

falita7
Level 3

Well, if anybody cares enough, here is a thread i made on the amd forums and maybe, just maybe someone from amd actually reads it.  

https://community.amd.com/t5/drivers-software/amd-drivers-and-vr/m-p/526584#M156416

Leaving a comment or a like will help, also tried getting an answer from somewhere but only the forums and the github repo is where the devs might read about this issue.

https://github.com/GPUOpen-LibrariesAndSDKs/Radeon-ReLive-VR/issues/132

 

With the old drivers everything works and all software related to vr runs without issue but we don't get any of the performance benefits (if any) from the newer releases or the updated UI for recording and updated fan control.

 

Nytevizion
Level 4

22.1.2 is working for me with Airlink. (It didn't before, I will explain below)

22.3.1 broke the encoder.

 

I used to use DDU to remove and install the GFX drivers but after reverting to 21.10.2 I tried upgrading through the AMD software using the "Upgrade" option and made it to 22.1.2 with the bitrate at good levels. This wasn't the case before as I always update to the latest version the day it's out like a dork. I don't know if it's relevant,  coincidence or what, but just an observation. 22.3.1 broke it again. Probably the RSR update.

 

I don't use ALVR, Relive or VD for the most part so I didn't test with those.

Screenshot (8).png

Z690 Gaming X-12700K-6900XT-16GB-3900MHz-DDR4-AIO MSI MAG Liquid

Ive tried half a dozen previous drivers, including 21.10.2, and nothing seems to change. Is there anything that needs to be done other than uninstall and reinstall the older driver? I see absolutely no difference between any of them.

I even tried 22.5.2 and that is actually really bad, things are jumping all over the place so looks like it kills the tracking as well.