Showing results for 
Search instead for 
Did you mean: 

Black Screen when using Virtual Desktop in Oculus PC App

Level 4

UPDATE: Solution found by Hansaplastique! THANK YOU!


It seems this method forces Intel(R) UHD Graphics to render for OVRServer_x64.exe. At least, that's what's selected under "Power Saving" for my PC. My games still run fine using this method, since they still use the GPU. The dashboard/OVRServer doesn't utilize the GPU while in use. Changing the preferred processor in Nvidia Control panel for OVRServer_x64.exe does NOT solve the issue, although I thought it would effectively accomplish the same thing. 


Many thanks to Hansaplastique. You're a real gamer. I made a video tutorial for the solution for anyone confused.


Original Post Below



Oculus app isn't showing desktop, just black screen. Though, I can still control the cursor with my controller. I have a Rift S and a Quest 2 and both have the issue. So far, I've restarted, repaired install, and installed latest graphics card drivers but have had no success. I also completely uninstalled and re-installed and am still having the issue. Currently blaming the recent update. My Quest 2 is running on v. 27, because v. 28 is not yet available to me. But I doubt that's issue because my Rift S also has the problem. 


OLD 4/25/21: I've been working with Oculus Support, but so far no amount of troubleshooting has solved the issue. My working theories are:


1. Nvidia Optimus laptops

2. The new update just glitched out the integrated Virtual Desktop in the Oculus PC application.


This issue is not present on my Desktop computer. I run VR on a MSI GL75 Leopard 10SFK-029. I'm still able to play games, and the black screen is my only symptom. 


CPU: i7-10750H

GPU: 2070 (mobile)

RAM: 32gb at 2933 MHz


I’m gonna give this a go when I get home. Thanks for the tip.

Level 3

I'm guessing we all have gaming laptops? I had the same problem but solved it. On my Zephyrus Duo I opened armoury crate and changed my GPU mode to Discrete from Optimus. 

think we could also fix it by disabling the built-in graphics chip, and forcing the monitors to use the GPU but haven't tested that yet.

Not sure all laptops have the option of disabling Optimus. And it used to work fine so something changed with the software update.

Yeah, even a user with the new version of my laptop (the user has a Zephyrus Duo 2nd edition) doesn't have the ability to switch between Optimus and discrete in armoury crate. I hope this is a software issue they fix quickly.

Go it to work properly now without the need for an external monitor:


Go to Windows Settings -> System -> Display -> Graphics Settings (way at the bottom).

Under "Graphics performance preference" -> "Choose an app to set preference" -> "Desktop app".


Click "Browse" and select: C:\Program Files\Oculus\Support\oculus-runtime\OVRServer_x64.exe

Click "Add".

Select "Options" and set it to "Power saving", and click "Save".

Restart the Oculus software and Virtual Desktop now works properly.


This worked for me on an 2020 AsusROG with an nVidia 2070.

View solution in original post

You're my hero ❤️

Worked for me also 🙏🙏

No. Works as intended on my desktop. But not my laptop (GL75 Leopard) See my latest post on the following thread...

i7 3770K, 32GB 1600mhz ,RTX 2070 OC 8GB, GA-Z68XP-UD3, Inateck KU5211 3.2USB Adapter, 1TB MX 500, (x3) Mushkin RAW SSDs, Antec 650w PSU Quest 2, X56 HOTAS, TrackIR 5 Pro, Win 10 Pro 20H2 19043.906

still didn't work for me

Remove the Oculus software using control panel then remove the Oculus folders in the following locations...


  • C:\Users\YourUserProfile\AppData
  • C:\Users\YourUserProfile\AppData\Local
  • C:\Users\YourUserProfile\AppData\LocalLow
  • C:\Users\YourUserProfile\AppData\Roaming
  • C:\OculusSetup-DownloadCache

Then download the Oculus software and do a clean install.

i7 3770K, 32GB 1600mhz ,RTX 2070 OC 8GB, GA-Z68XP-UD3, Inateck KU5211 3.2USB Adapter, 1TB MX 500, (x3) Mushkin RAW SSDs, Antec 650w PSU Quest 2, X56 HOTAS, TrackIR 5 Pro, Win 10 Pro 20H2 19043.906