Showing results for 
Search instead for 
Did you mean: 

Blade and sorcery won’t download again

Level 2

I’ve had blade and sorcery for a while and have had no problems. Today when I turned on my quest 2 it said it had to update, when I did it stoped and said it was unable to update. I tried uninstalling it but it won’t remove itself. It also is infinitely loading so I can’t check the details. But it just keeps asking me to retry the download. Couldn’t find anything that worked so I’m here. 


Community Manager
Community Manager

Hi SaltyScales! We're sorry to see Blade & Sorcery has stopped updating. We know how frustrating this must be, and we want to help get you back in the game.


We are aware that some people are not able to properly install apps on their Quest library. If you have a game or app that seems stalled for more than a few hours, ensure that you have the Cloud Backup feature enabled then perform a factory reset. Once completing these steps the updates should resume.


We know a factory reset is never ideal, but this is the only solution to this issue at the moment. We hope this helps.