cancel
Showing results for 
Search instead for 
Did you mean: 

Buttons not working in games

Zuruumi
Level 2

I have problems with my new Oculus Quest 2. The buttons on both controllers work in the menu (and strangely Youtube VR), but they do not work in games (Superhot demo, Beat Saber+Beat Saber demo, Creed Rise to Glory demo, VR Chat tested). Tracking works, the trigger (and oculus home) works, but buttons (A, B, X, Y, possibly joystick, though that one likely just does nothing anyway) are not registered, so the game is stuck on first need to click (Beat Saber, Creed, VR Chat) or shooting doesn't work (Superhot). Also strangely in Creed on "click any button" clicking A works, but on "Next page" it doesn't (and no other button too), so I would say it is a problem with mapping, but there is no way to remap (and I haven't messed with anything).

 

Setup: standalone (can't test with PC as it isn't compatible), no experimental features on, applications downloaded through oculus store

 

I have tried:
-unpair/pair controllers
-(unpaired or not, both), remove the battery from controllers for 5min, put it back
-restart headset
-headset factory reset

Nothing seemed to work.

1 ACCEPTED SOLUTION

Accepted Solutions

Zuruumi
Level 2

Solved (I was an idiot and missed one button that worked).

View solution in original post

7 REPLIES 7

Zuruumi
Level 2

Solved (I was an idiot and missed one button that worked).

jovan.876
Level 2

So what was the solution?

neilmk
Level 2

I’m having this exact issue with a brand new Oculus Quest 2. I’ve tried all the same steps as you with no joy. 

 

could you please share the specifics of how you resolved it please? 

I Cannot click any buttons in any games only and therefore can’t play anything. All other buttons; settings, YouTube, Netflix etc work fine. 

Hey @neilmk we noticed you're having the same issue of your controller buttons not working in games after attempting all the troubleshooting above. We're so sorry to see your first experience with your new Quest 2 is a negative one. We want to do everything we can to get you into the wonderful world of VR.

 

Please submit a support ticket with our team so we can look into possible further troubleshooting and options for you. 🙏

I'm having the same issue, and am finding many other reports of this, though I haven't found any resolution posted. Can you please advise on this? My Oculus is useless without being able to use the buttons inside games/apps even though the buttons work in the regular menus.

Did you get any resolution to this issue?

Hi there, sorry for my late reply. The answer was embarrassingly simple...

 

You need to use the top triggers at the front of the controllers when you're in games.

 

I didn't even see them because when you're wearing your headset you are feeling for the 'natural' buttons and triggers that we're used to on the likes of Xbox and PS controllers. But Oculus have those 2 triggers at the front, top of the controller. 

 

I hope this helps!