cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot Install Oculus Rift Drivers (Logs Inluded)

amgrabowska
Level 2
Hi Everyone,

I have just purchased an Oculus Rift and the setup recognizes my headset but not my sensors, they are present in device manager as CV1 External Camera. I have done extensive troubleshooting by myself but to no avail. I have narrowed down the issue to a problem during installation of the drivers. During setup, it prompts me to update the drivers, and I do, but when I start the setup again it prompts me again in an endless loop. I have done some looking into the AppData/ logs which I will attach and include snippets below and can see that there are failures installing the drivers. I am not sure of the cause of these failures though. Any insight is greatly appreciated, I would really like to start using my rift soon! I have done the installation from the default Windows Administrator account with all Occulus AppData and ProgramFiles folders deleted (Fresh Install).

I have a computer above and beyond the spec required for Oculus (GTX 1070, AMD-FX8350, 16GB memory, 1TB SSD)

Errors in OculusDriverInstaller... log
<code>[Debug] [1/6/2018 2:57:31 PM] Beginning installation of Monitor Driver - Driver package 'C:\Users\Administrator\AppData\Local\Temp\OculusDriverInstaller\RiftDisplay.inf'
[Debug] [1/6/2018 2:57:31 PM] DevPresentOnInstall = False
[Info] [1/6/2018 2:57:31 PM] DriverPackageInstall(DRIVER_PACKAGE_ONLY_IF_DEVICE_PRESENT) result: ERROR_NO_SUCH_DEVINST - Device not detected (not plugged in) right now
[Error] [1/6/2018 2:57:32 PM] DiInstallDriver() error message: The remote procedure call failed
[Debug] [1/6/2018 2:57:32 PM] Ending installation of Monitor Driver
[Info] [1/6/2018 2:57:32 PM] FAILURE! Failed to install driver: Monitor Driver
[Debug] [1/6/2018 2:57:32 PM] -------------------------------
[Debug] [1/6/2018 2:57:32 PM] Beginning installation of DK2Sensor Driver - Driver package 'C:\Users\Administrator\AppData\Local\Temp\OculusDriverInstaller\RiftSensor.inf'
[Debug] [1/6/2018 2:57:32 PM] DevPresentOnInstall = False
[Info] [1/6/2018 2:57:32 PM] DriverPackageInstall(DRIVER_PACKAGE_ONLY_IF_DEVICE_PRESENT) result: ERROR_NO_SUCH_DEVINST - Device not detected (not plugged in) right now
[Error] [1/6/2018 2:57:33 PM] DiInstallDriver() error message: The remote procedure call failed
[Debug] [1/6/2018 2:57:33 PM] Ending installation of DK2Sensor Driver
[Info] [1/6/2018 2:57:33 PM] FAILURE! Failed to install driver: DK2Sensor Driver
[Debug] [1/6/2018 2:57:33 PM] -------------------------------
[Debug] [1/6/2018 2:57:33 PM] Beginning installation of Tracker Driver - Driver package 'C:\Users\Administrator\AppData\Local\Temp\OculusDriverInstaller\OCUSBVID.inf'
[Debug] [1/6/2018 2:57:34 PM] DevPresentOnInstall = False
[Debug] [1/6/2018 2:57:34 PM] DriverPackageInstall(DRIVER_PACKAGE_ONLY_IF_DEVICE_PRESENT) result: 1726
[Error] [1/6/2018 2:57:35 PM] DiInstallDriver() error message: The remote procedure call failed
[Debug] [1/6/2018 2:57:35 PM] Ending installation of Tracker Driver
[Info] [1/6/2018 2:57:35 PM] FAILURE! Failed to install driver: Tracker Driver
[Debug] [1/6/2018 2:57:35 PM] -------------------------------
[Debug] [1/6/2018 2:57:35 PM] Installing driver
[Debug] [1/6/2018 2:57:35 PM] About to invoke devcon with cmd: remove, in install step: InstallDriver
[Debug] [1/6/2018 2:57:35 PM] StdOut: No devices were removed.

[Debug] [1/6/2018 2:57:35 PM] StdErr: 
[Debug] [1/6/2018 2:57:35 PM] Devcon completed successfully
[Debug] [1/6/2018 2:57:35 PM] About to invoke devcon with cmd: install, in install step: InstallDriver
[Debug] [1/6/2018 2:57:36 PM] StdOut: Device node created. Install is complete when drivers are installed...
Updating drivers for Root\Oculus_ViGEmBus from C:\Users\Administrator\AppData\Local\Temp\OculusDriverInstaller\Oculus_ViGEmBus.inf.

[Debug] [1/6/2018 2:57:36 PM] StdErr: devcon.exe failed.

[Info] [1/6/2018 2:57:36 PM] FAILURE! Failed to install driver: Gamepad Emulation Driver
[Debug] [1/6/2018 2:57:36 PM] -------------------------------
[Debug] [1/6/2018 2:57:36 PM] About to start audio device
[Debug] [1/6/2018 2:57:38 PM] Process C:\Users\Administrator\AppData\Local\Temp\OculusDriverInstaller\Audio_Enable.exe exited with code 0 (success).
[Debug] [1/6/2018 2:57:38 PM] Beginning installation of Audio Driver - Driver package 'C:\Users\Administrator\AppData\Local\Temp\OculusDriverInstaller\Win10\oculus119b.inf'
[Debug] [1/6/2018 2:57:39 PM] DevPresentOnInstall = False
[Info] [1/6/2018 2:57:39 PM] DriverPackageInstall(DRIVER_PACKAGE_ONLY_IF_DEVICE_PRESENT) result: ERROR_NO_SUCH_DEVINST - Device not detected (not plugged in) right now
[Error] [1/6/2018 2:57:40 PM] DiInstallDriver() error message: The remote procedure call failed
[Debug] [1/6/2018 2:57:40 PM] Ending installation of Audio Driver
[Info] [1/6/2018 2:57:40 PM] FAILURE! Failed to install driver: Audio Driver</code>


Only warnings from OculusSetup.txt
<code>[Warning] [1/6/2018 2:58:44 PM] Error submitting Marauder packet:
System.Threading.Tasks.TaskCanceledException: A task was canceled.
[Warning] [1/6/2018 2:58:44 PM] Exception deleting 'C:\Users\Administrator\AppData\Local\Temp\OculusSetup-d76d384b-995a-4cda-bde6-8a0ae908e757':
System.UnauthorizedAccessException: Access to the path 'DaybreakNative.dll' is denied.
   at System.IO.Directory.DeleteHelper(String fullPath, String userPath, Boolean recursive, Boolean throwOnTopLevelDirectoryNotFound)
   at System.IO.Directory.Delete(String fullPath, String userPath, Boolean recursive, Boolean checkHost)
   at Dawn.Mixins.ReallyDeleteDirectory(String path)
[Warning] [1/6/2018 2:58:44 PM] Exception deleting 'C:\OculusSetup-DownloadCache':
System.IO.IOException: The directory is not empty.</code>
4 REPLIES 4

Pcacella
Level 2
I have the same problem.

MAC_MAN86
Level 9
Delete that Driver but not remove the driver software. Try switching PC OFF, disconnect your HMD on both cables and Sensors too. Restart PC. Switch OFF. Reconnect HMD only. Restart PC and run Oculus then Run SETUP and then plugin your USBs.
WIN10 does not fully close APPs to allow Firmware and other Updates to complete is the issue.

Pcacella
Level 2
Nothing you mentioned works. It seems a bug in driver installation, not a windows issue.

Mafankulo
Level 2

Pcacella said:

Nothing you mentioned works. It seems a bug in driver installation, not a windows issue.


Same issue but mine is with the headset Im thinking its a bug aswell and its related to RiftDisplay.inf