Showing results for 
Search instead for 
Did you mean: 

Cannot update apps on Oculus Home - please help!

Level 3

Hello Oculus friends!

I'm having a strange problem where I cannot update my Rift apps that currently have pending upgrades to install. Each one will download and then it just tries to install the update (counts from 1 - 100%) and the I get an error message saying: "Sorry, Oculus home could not installl *name of application*. Try contacting support."

I have home 1.11. The pending upgrades are Medium 1.04, Dead and Buried, Lucky's Tale, Bigscreen Beta.

Other notes: I have tried closing and reopening home, signing out and back into home, restarting the computer...even The beta reset.

Thoughts? Have any of you experienced this?


Level 3

I have the exact same damn problem, reported it to Oculus Support, got the general response, is your computer plugged in, bullshit questions, told them exactly what you said and haven't heard a word back!

This is total BS especially not letting us know they recognize the problem and are working on it!!

Level 5

Look in the Oculus install folder in Program Files & see if you have the redistributables folder install each one manually if the folder is there (could be the problem, not saying it is)

I have never seen that error and currently my rift is being RMA'd so can't look, otherwise try a repair install with the OculusSetup.exe.

edit: glad you have you rift up and running again 🙂

Level 9
Same problem here with Alt Space, Rec Room and Bigscreen.

I did get a Dead and Buried update through in my case.
Asrock Z77 Extreme 4 + 16GB RAM 1866mhz + i5-3570K at 4.5Ghz + Coolermaster Nepton 140XL cooler Sapphire 8GB RX 580 Nitro+ 256Gb SDD Samsung Evo 850 +3x2TB in raid 0 with 64GB SSD cache Thermaltake Level 10 GT Snow Edition + Toughpower 875w

Level 3
I did the repair install, didn't do a thing. I will try to see if I have a redistributables file 

Level 3

Never had a single problem with the rift before, not one. Worked perfectly

Where are the Oculus and Gun Slinger tech guys?! on this.

Level 5
Sorry if it did not fix, damn wish oculus would have invested some of that money in it's operating software. It's great that they invested money in apps and games but "cart before the horse" and all that.

Hope they get this sorted soon :s

Level 3
Where is the support, if I knew they acknowledged the problem and were working on it I would be cool, but instead all I hear is Crickets

Level 7
I have a similar issue with fresh install of Oculus Home as directed by Oculus support. I already updated my ticket. Hopefully I will get a response back soon. 
CPU: Intel i5-4690K Mobo: ASUS Z97-AR Ram: 8GB 1600MHz Graphics Card: EVGA GTX 1080 SC

Level 15
Can you all please upload your log files?
AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV