cancel
Showing results for 
Search instead for 
Did you mean: 

Compositor Frame Drops Every Second (Stuttering in Headset)

OwynC
Level 2
Hey Oculus Forums, I recently started getting stuttering in my rift. It happens every second like clockwork and is displayed as dropped compositor frames in the debugger. 

Here's a link to a similar issue.

l7wpebe7d267.jpg

c3xm0fbomq5w.jpg

I have a i5-4460 8GB of ram, a GTX 1070 and Windows 10 64bit. Although the CPU is not up to minimum system spec I haven't had any issues so far and have had my rift since this May. I'm currently running Oculus Home 1.9 and Nvidia Driver 375.70

Any help would be appreciated, I believe the issue may be related to either the recent Oculus 1.9 update or the latest Nvidia driver update.

Edit: I rolled back my drivers to 368.81 and nothing changed. 

Edit2: I completely reset Windows, formatting the drive and removing all software. I reinstalled Oculus Home and a couple VR of games to test. I still got compositor frame drops from the default automatic Windows installed drivers. I then downloaded Geforce Experience and updated all my drivers to the latest. I still get the compositor frame drops. This is probably an issue with oculus home 1.9.

Edit3: I enabled ASW and still get the compositor frame drops.
28 REPLIES 28

cybereality
Level 16
I believe this is an Nvidia driver issue, but I thought it was fixed.
AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV

OwynC
Level 2
It may be but the frames drop and stutter even when I rolled back to the Nvidia Driver 368.95.

YoLolo69
Level 10
You don't have any "major" program running at the same time? I once had the same issue just due to browser Chrome opened when running my games.

“Dreams feel real while we are in them, it's only when we wake up that we realize something was strange.” - Dom Cobb

"Be careful, if you are killed in real life you die in VR too." - TD_4242

I7 10700K,  RTX 3070, 32GB DDR4 3200Mhz, Oculus Rift CV1

OwynC
Level 2
Nope, everything else is closed. In task manager oculus is the largest and only major resource intensive program. Also I didn't have this issue before updating the Nvidia drivers and oculus home.

neuro27
Level 3
Same issue here! Everything worked wonderfully a few days ago, now it's not working nearly as well

Techy111
Volunteer Moderator
Volunteer Moderator
Try 368.81. That has been by far the most stable driver.
A PC with lots of gadgets inside and a thing to see in 3D that you put on your head.

neuro27
Level 3

Techy111 said:

Try 368.81. That has been by far the most stable driver.


Thank you! This helps a little bit in VR Desktop, but not in my other apps it seems.

Is there any way to go back to 1.8?

Palidore
Level 3
Hey guys, so I've been having this problem recently as well, but may have found a solution.

First: Open up Nvidia control panel, go to "Set up stereoscopic 3D," and make sure it's disabled, i.e. uncheck that box, if it isn't already.  Note that this step might not be necessary, but I've read in my online sleuthing that in the past at least, that enabled 3D vision was giving people stuttering.

Second, and what seemed to fix my frame drop problems: Open task manager, scroll down under the Background Processes category, and see if you can find a process with an Nvidia logo called "Stereo Vision Control Panel API Server" or something like that .  End that process, and see if the stuttering issue goes away.  For me, it seemed to instantly stop the application and compositor frame drops that I was seeing on that Oculus performance overlay. 

Really hope this helps guys! I know how aggravating of an issue it is, believe me.  Crossing my fingers that this was the main culprit, and that the issue doesn't pop up again. 😕

EDIT: Aaaaaaand it's back again. Kinda.  I don't know why ending that process stopped the judders momentarily, but sure enough they came back.  Keeping Chrome completely closed seems to help...maybe...but can't say definitively, will have to look at it more when I'm less tired.  Kinda spent on trying to solve this problem tonight.  Anyway I'll report back if I find a more reliable solution.

SocialAnxiety4M
Level 2
was a solution ever found? i'm having the exact problem as OwynC, rolling back drivers didn't help 😧