cancel
Showing results for 
Search instead for 
Did you mean: 

Consistantly stuttering/lagging and black borders every 10 to 20 seconds

MickGerritsen
Level 2
Good evening Oculus users and the team of Oculus,

I have been enjoying virtual reality some times using my powerful VR-ready gaming laptop. Last year I have played VR games with the original Oculus Rift and it ran very well on my laptop without any problems at all and at the moment I am using the Oculus Rift S. But right now I am dealing with a really annoying stuttering problem on the Rift S connected to the same laptop and I don't know what causes the problem after investing a lot of time in research and testing. The problem will make games unplayable for me.

The problem I am having is that in all games and even in the Oculus home app, gaming will quickly become unplayable after a while because of big stutters. Games will slowly ramp up in stutter/frame drop and will become more laggy over a periode of around 10 seconds, then they will reach their peak in stutter and lag and sometimes I can see a black border because the VR-display can't be rendered. After this has happened, everything will run smoothly for around 5 seconds and after that I can feel and see it run more laggy again. Even in the Oculus home app, it will have this problem with at its peak stutters every 15 seconds, I can see black around the current rendered screen because of the stutter. It is a consistent type of lag/stutter that will come back in time intervals in every game and makes everything unplayable. I have found an interesting piece of information:

My GTX 1070 max-q will go up and down in usage in the same tempo and time interval of the lag/stutter that will ramp up and be gone after some seconds.
nuot0m8oxjvh.png


My laptop is running the following specs and thus is vr-ready:
- Intel core i7 8750h
- Nvidia GTX 1070 max-q
- 32 GB's of RAM memory

I tried to find a solution for this stutter/lag problem by doing all of this:
- Making sure the laptop isn't thermal throttling during VR.
- Making sure the laptop isn't power limit throttling during VR.
- Clean install of Windows 10 and updating to latest version.
- Reinstall the Oculus application.
- Update all drivers.
- Testing non-VR games and my laptop runs GTA 5 on high graphic settings fine.

If someone could help me with the problem, that would be very appreciated! Because I would really like to enjoy playing VR on the Rift S with my laptop again.
Thank you in advance!

Mick
10 REPLIES 10

PITTCANNA
Level 13
in the menu, there is a setting to prioritize performance over quality.  try going to into the headset settings menu and try that.

https://oxfordmedicalsimulation.zendesk.com/hc/article_attachments/360041932293/11.png


MickGerritsen
Level 2
@"matthew.canna" Thank you for the post! I will try out the performance setting and give an update about the problem soon

PITTCANNA
Level 13
also you might want to go into the nvida menu and use all option for increased performance. after a clean install and driver updates everything goes back to a default state, where it goes for more quality.

MickGerritsen
Level 2
Thanks for the suggestions! They didn't help me get rid of the stutter. It is a strange problem because it also happens just while looking at a plain wall. And at a consistant time interval the stutter will go up and down and when it is gone for a few seconds everything is very smooth. It isn't something I experience in other non VR pc games

PITTCANNA
Level 13
try this 
by rolling back the Nvidia drivers to version 442.59 (04/10/2020).

or 
"If your getting a frame drop at semi regular intervals, and it also not just VR games. the culprit is steam trying to update/authenticate a pre-loaded games which is most likely HL:A

tell steam to not download or update while you are playing games

PITTCANNA
Level 13
also try different usb ports on your computer.

MickGerritsen
Level 2
I don't play Half Life Alyx and the problem exists with both Oculus and Steam VR games. I could try the USB ports. And there is a chance that it may be a port problem

MickGerritsen
Level 2
After trying out other ports I still get the same results

Hello from 2021, have you find a solution?