cancel
Showing results for 
Search instead for 
Did you mean: 

DK2 - no head tracking at all

JasonAhart
Level 2
I've been at this for two whole days. I'm at my wits end. There is no head tracking AT ALL. Period. The only thing that has worked is the test demo scene in the configuration utility. No matter what I try nothing works. Most of the time when I try to run the config utility I get "Oculus VR service is unavailable". There is an unidentified error in Event Viewer as well. I tried the long list of steps Bilago posted in another thread. I followed it 100% and still no head tracking. I'm using games made for the new SDK as well, not older ones. The camera lights up and the headset lights up (extended mode, direct mode sends the video directly to the monitor instead of the Rift). The config utility sees the rift and the camera. I've tried every single USB port on the PC. I don't know what else to do. I've installed and uninstalled the runtime probably 30 times now. Why can I not get head tracking in anything except the config demo?
i5 3570K GeForce 980 GTX 16 GB RAM Windows 7 64bit
42 REPLIES 42

JasonAhart
Level 2
Wow. Uninstalled the SDK 4 runtime and re-installed it and now Windows immediately no longer recognizes I have a video card. Reinstalled the GeForce drivers (where they went, who the heck knows). Now my Samsung TV shows up as "default monitor" and some low and unchangeable resolution and Windows Aero theme is no longer an option. Just when you think it couldn't get any worse. I knew this would be buggy since it's a developer kit but this really is crazy.
i5 3570K GeForce 980 GTX 16 GB RAM Windows 7 64bit

JasonAhart
Level 2
Well now I know what happened. installing the runtime did this to GeForce:

Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged. (Code 19)

:evil:
i5 3570K GeForce 980 GTX 16 GB RAM Windows 7 64bit

malospam
Level 2
It does weird stuff to my monitor too sometimes, like maximizing my resolution on my main screen to 1024 by 768 or something like that. I don't know why they couldn't just increase the resolution on the original oculus and leave it at that to make it work easy.

JasonAhart
Level 2
I'm not giving up on this. Thankfully I was smart enough to do a backup and an image before I ever tried to install it. I know this is an unfinished product so bad things can and will happen. I've re-imaged and restored all files back to the way it was before I ever installed the Rift. I'm going to try again and post results of what happens when I try an install with no Logitech mouse attached. Also, I found a video of someone saying they definitely had issues with USB 3 but that using a USB 2 hub got around the problem. I have an old USB 2 in the basement somewhere. I'm going to try that too and post results later.
i5 3570K GeForce 980 GTX 16 GB RAM Windows 7 64bit

malospam
Level 2
Jason, that would be great if you could post your results here and may be some of us can benefit. Thanks so much 🙂


Visit my Unity/Unreal Blog at
http://unity-unreal.blogspot.com/

zookone
Level 2
My DK2 had a LED error:

[HMDTrackingModel] Incorrect LED 13 position version: 1. Make sure that the bundle adjustment has been performed correctly.

This was stopping my DK2 from being recognized fully in the Config. Utility from working. I got it working for the moment with the Unofficial "OVRService_x86_patched.exe"

I have submitted a support ticket. From reading other posts I think I have hardware defect that will require replacement. Waiting to hear back from Oculus support.

JasonAhart
Level 2
I reimaged my computer. I removed the Logitech mouse and used an old Dell mouse.
Result= no head tracking

I plugged in a USB 2 hub and plugged the camera and headset into that. Powered the hub as well.
Result= no head tracking

The HDMI cable on the headset frequently wobbled and lost connection. I replaced it with a new HDMI cable. Unfortunately the USB connector on the headset keeps wobbling around and dropping connection with the computer. At this point I'm pretty certain I may have a defective headset.
i5 3570K GeForce 980 GTX 16 GB RAM Windows 7 64bit

malospam
Level 2
Damn Jason, I was really hoping you would get some results out of that. So is there a definitive way to know if your headset is defective? If we could run some sort of utility or if the developers had some sort of method that would be great. I hate to just guess and waste more time and more money. Let me know if you find out anything else Jason.

JasonAhart
Level 2
I have no idea. The config demo (with the desk) works perfectly. head tracking, positional tracking and everything but that is the only thing that has ever worked. No other app works at all regardless of whether it was made for SDK3 or 4. I'm also constantly getting errors saying the OculusVR service is unavailable. I stop it and restart it and 10 seconds later it's unavailable again. When it finally starts and actually stays started I can get the config demo desk scene open and then the headset goes black. It pops back on for a bit and then turns off again. I've noticed when the headset goes black the blue light turns off and the config demo says no headset is connected to the computer.

I load up an SDK 4 game and I have no head tracking or positional tracking even though the config tool says the camera and headset are both connected. So I give up and walk around with the mouse instead. The headset goes black. It comes back on a few seconds later, keeps working for a minute and goes back off again. I'm pretty sure the ports on top of the headset are bad and that's why I lose connectivity. I don't know if that has anything to do with why the head tracking is an issue. Like I said, the config "desk demo" works perfectly. Nothing else does though. Not even Tuscany has head tracking. What exactly is different about the config desk demo scene from everything else? The one thing I notice that is certainly different is that when you run the config demo it opens straight into the rift. Nothing else does. it doesn't matter if the rift is set to direct mode or extended mode. Absolutely nothing opens to the rift. And I'm using the direct to rift exe files. I've tried making the rift the primary display. I've tried switching to extended and dragging the game to the rift. I've tried the shortcut trick with -adapter 1 added to it. Absolutely nothing at all works (other than the desk demo) and I cannot figure out why.

Does the config desk demo scene at least work for you too?

At this point the only thing I can think to try now is to spin up a virtual machine of Windows 7 with absolutely nothing at all installed on it except for my video card obviously. I don't know when I'll have time to try that at the moment. I've already dumped a week into this and have gotten nowhere. I will say this... the desk demo was an amazing experience. Even when the rift only half ass works you are blown away by it. If only I could see what it's actually supposed to do.
i5 3570K GeForce 980 GTX 16 GB RAM Windows 7 64bit

Hammerschaedel
Level 2
Are you using win 8.1?