cancel
Showing results for 
Search instead for 
Did you mean: 

Disconnecting Link Cable Quest 2

Tonicc_
Level 2

My Oculus Quest 2 keeps randomly disconnecting from 0-60 minutes after being in use, Oculus link works fine with other USB cables and I have written out the possibility of it being a faulty Type-C port or cable by testing different combinations. I have already tried possible fixes such as disabling power limitations but it still crashes while using the Type-C port. The reason I wish to use this port over other USB ports is because this is the only one which keeps my headset at full charge.

 

Oculus app version 38.0.0.51.727 (38.0.0.51.727)

GeForce Game Ready Driver Version: 5.11.79

Ryzen 5, 3600
RTX 3070 Gaming OC

16GB 2666 RAM

AORUS B450 PRO WIFI Motherboard

9 REPLIES 9

jonny_b_1990
Level 3

Could I ask whether you're running USB 3.0 or 2.0 when using a USB A port? I've found that I get a stable link connection (for several hours) using USB 2.0, but when trying to use a USB 3.0 cable (both Type A and Type C) it will disconnect completely randomly, sometimes in half an hour, sometimes within a minute.

Only got USB 3.0 ports but sounds like the same disconnection problem.

OculusSupport
Community Manager
Community Manager

Hi friend, we noted that you've encountered some connection issues with your headset, and we'd be more than honored to assist! We'd like to collect your log files to get an internal perspective of the error you've come in contact with. We ask that you create a support ticket including this essential information on our official Oculus Support channel so that we can further evaluate the data.

The same thing has been happening to me and i have tried every "fix" in the book it seems. Please let me know if this issue gets resolved.

jonny_b_1990
Level 3

This has worked for me:

Try to also install the latest Oculus drivers by following the steps below:
Close the Oculus app.
Press the Windows key + R on your keyboard to open the Run command.
Enter C:\Program Files\Oculus\Support\oculus-drivers.
Open oculus-driver.
Open the Oculus app and then try to connect your headset again.

A "check for updates" button in the app would definitely be on my priorities list if I were them haha

I'm experiencing very similar with you Jonny, whenever I use my USB 2.0 cable (Type A), I never get disconnected...but whenever I use my USB 3.0 cable (Type C - I only have this, and this is not the official oculus link cable. I even see people mentioning in forums that although they use the official oculus link cable, this random disconnection also happens), I got random disconnection, and you're right sometimes half an hour, sometimes within a minute, sometimes couple of minutes... can Oculus / Meta team solve this problem? Because indeed using the USB 3.0 cable, I could feel the quality is better (visual and also sound), although not significant.

I tried this but sadly still does not work for me...

Hello NikZ6. We understand that you've ran into some connection issues. We're more than happy to assist you with this. Can you please submit a ticket with log files to get an internal perspective of the error you've come in contact with? Once we have this vital information we'll be able to better assist you. We're looking forward to hearing from you! 

Thank you for your feedback, I just submitted the ticket along with my log file attached to the support. Hope you can help me. Thank you.