cancel
Showing results for 
Search instead for 
Did you mean: 

[FIXED] Quest 2 PC Link Black Screen (But Audio and Desktop Mirror work)

Aussywoo
Level 3
UPDATE (12/7/2020): I was able to get past the hurdle I describe below, but there are still issues. "Solution" is at the bottom.

I recently purchased the Quest 2 with the intention of utilizing both the standalone and PC functionalities. While the standalone version works with virtually no issue, Oculus Link has been driving my head through the ceiling and beyond.

FINAL UPDATE (12/16/20): My issues have been completely fixed, thanks to a suggestion sent in by a reply. A video titled "FIX OCULUS LINK/RIFT PROBLEMS on GAMING LAPTOPS - AMD/NVIDIA iGPU dGPU (Black Screen Issue) Quest 2." suggested that users with a similar hybrid GPU setup to mine use Window's direct graphics settings instead of Nvidia's control panel.

Original post:

My equipment:
HP Omen 15 Laptop (Ryzen 5 4600h, GTX 1660 Ti, 16gb RAM)
Oculus Quest 2
Included Charging Cable as a Link Cable (I am aware that it is a USB 2.0 connection -- I'm only testing at the moment)

Here's what's functioning:
Upon confirming that I want to run Oculus Link, the Oculus software does indeed open on my desktop. Checking in the devices section tells me that both controllers along with the headset are connected, though a USB 3.0 connection is recommended.

Here's what's not functioning:
The headset display itself doesn't display anything besides an occasional loading sign along with the guardian boundary warnings (since the charging cable only allows me to hover near my desk). I decided to open VRChat via the Oculus software to see what would happen. Opening the game doesn't display any errors. In fact, when I move my headset around, I can see my desktop version moving around along with the controllers. Sound does come through the Quest with no issues. The display continues its habit of showing the occasional loading sign.

I decided to try with the SteamVR version of VRChat. The results are a bit worse and confusing. In all scenarios, the VRChat client loads up frozen on the menu screen (though it is sometimes tilted as if my headset was tilted). The SteamVR window displays one of two things on any given occasion. The first, and most common, is where it shows the headset and two controllers connected, but has an error message above it stating there is a problem preventing it from working correctly. The second scenario simply shows no errors but still remains frozen.

Note: I opened both VRChat versions through my actual monitor.

Here's what I know:
  1. My laptop is capable and supports running VR
  2. Both my USB Type A and C are 3.0 and backwards compatible.
Here's what I've tried (in no particular order):
  • Restarting my PC
  • Restarting my Quest 2
  • Restarting the Software
  • Updating my graphics drivers
  • Using Nvidia Control Panel and setting Oculus Dash and other processes to use my dedicated graphics card
  • Trying a different cable (USB A to C through USB 2.0)
Here's what I have not tried, but plan to (in order):
  1. Reinstall the Oculus Software
  2. Reinstall my USB Drivers
  3. Factory reset my headset
  4. Buy an alternative Oculus Link Cable
  5. Give up
What I need help with:
Based on reading through other posts with similar issues, my guess is that there isn't just one known fix that should work. However, I would like some guidance on what to try or modify first. I just want to play Beatsaber.

Appreciate any help I can get!
Aus

Temporary Workaround (12/7/2020): Upon watching a video on the topic, I found out that my issue was caused by some sort of oversight/bug through Oculus Link's graphics recognition. Hybrid graphics cards setups (like in most gaming laptops), where some processes run on the dedicated card while others run on integrated graphics, cause Oculus to freak out and die. Going into the Device Manager and disabling the integrated GPU under Display Adapters fixed a lot of issues (after a restart). This came with the disadvantage that my laptop is now stuck at the lowest brightness because it now thinks that I'm using an external monitor.

Upon starting up Link and all that jazz, my Quest finally started outputting -- with ZERO LAG! What didn't have zero lag were all the games I tried playing though. VRChat, from the very beginning, had framerates of around 2 per second. Google Earth refused to start at all. Minecraft got a bit further, showing a zero-lag loading screen but then getting stuck at a red screen while eating up 50% of my CPU power.

After a bit more research, I found that if AMD is involved in any way (like my setup is) then Oculus will have further issues as well. What this tells me is that Oculus Link hasn't really been optimized for anything other than an Intel/GTX build. I've had friends with AMD processors that have had no issues, but it looks like a good chunk of people run into similar problems as me.

I'm unable to post links at this time, but the video I mentioned, by Sergeant Nathan, is titled "Oculus Link Black Screen Workaround".
7 REPLIES 7

aarrodri
Level 2
Thanks for the tip ! It worked for me too. Have you found another solution ?

V12Vinnie
Level 2
Holy crap I am totally in the same boat. I am soooo damn dissapointed - anything that isn't just runnning it standalone is just such a bloody faff. Have now gotten it to kinda work using your method of disabling the integrated AMD graphics processor, but it shouldn't be this difficult...

Specs: 4800HS and an RTX2060 max-Q

aarrodri
Level 2

V12Vinnie said:

Holy crap I am totally in the same boat. I am soooo damn dissapointed - anything that isn't just runnning it standalone is just such a bloody faff. Have now gotten it to kinda work using your method of disabling the integrated AMD graphics processor, but it shouldn't be this difficult...

Specs: 4800HS and an RTX2060 max-Q


There is another solution insinde windows where you can force the system to use the high perfomrance graphic card instead of the crappy integrated one. I tried it yesterday and it worked. CHeck out this one :  
SEarch in youtube for : 

FIX OCULUS LINK/RIFT PROBLEMS on GAMING LAPTOPS - AMD/NVIDIA iGPU dGPU (Black Screen Issue) Quest 2

By Phillip Neitzel

V12Vinnie
Level 2
I did try something similar earlier yesterday, and it didn't seem to help 😕

Having said that - I will try again today as I also saw that this video assigns it to a different file than the one I was assigning to yesterday.

Aussywoo
Level 3

aarrodri said:

Thanks for the tip ! It worked for me too. Have you found another solution ?


At this time, no. I'll take a look at the suggestion you posted though. Appreciate it!
V12Vinnie said:
Holy crap I am totally in the same boat. I am soooo damn dissapointed - anything that isn't just runnning it standalone is just such a bloody faff. Have now gotten it to kinda work using your method of disabling the integrated AMD graphics processor, but it shouldn't be this difficult...

Specs: 4800HS and an RTX2060 max-Q

Rest assured, I'm still searching through potential fixes to this that don't involve just going wireless and compromising. But in the end, Oculus Link is still very much in beta, so these kinds of issues aren't exactly surprising.

Aussywoo
Level 3
Update: Holy crap the video suggestion worked.

kellerbgolden
Level 2
hey im having the same problem, but i dont have intergrated graphics/not a laptop
these are my specs:
AMD Ryzen 7 2700X eight-core processor
Radeon RX 580 Series