cancel
Showing results for 
Search instead for 
Did you mean: 

Fix for Herobound: spirit champion crash / not loading, OVRPlugin.dll needs downgraded

shrimp24201
Level 2
The story:
Sometime this summer 2018 after an Oculus software update our Herobound spirit champion software started crashing on startup with an error dump and no real useful information on the crash.  I thought it was the video drivers and went back and forth to no avail.  After emailing the devs multiple times with no response I took a deeper look as this is one of our favorite games.  After many days and weeks of trial and error I can finally post what fixed it on our machine!

The fix: I figured it must be some new file causing the issue as it used to run flawlessly.  So I tried looking through the files and found the plugins folder.  I compared many of these files to some other Oculus apps / sw on my machine and found that the culprit was OVRPlugin.dll.  When replacing the newer 2018 ver with an older one it worked again!.  I wanted to give back to the Oculus community and I have attached the older version.  Simply make a backup of your existing plugin -> rename to OVRPlugin.old to be safe and then unzip OVRPlugin.dll and replace with the attached in the following folder.
<Your drive>\<Your directory>\Oculus\Software\gunfire-games-llc-herobound-spirit-champion\HeroBound2_PC_Data\Plugins
I hope this helps you get the game working again if you are having the same crash condition!  If it does please leave some feedback as this is my first post. 
4 REPLIES 4

rh_galaxy
Level 7
Yes, it works with your DLL, thank you. Since it is in the game directory it must come from an update of the game, and not from an Oculus Home update, or maybe an Oculus Home update broke this one from working... Probably the later since there is no reason to update an old working game.

Miss the ability to see dates for last update in OH.

KNP54
Level 7
Yeah the game works again finally.
Although, if you don't trust downloading the file from Mr. NobodyFromTheInternet (no offense @shrimp24201), I tried several OVRPlugin.dll from various games I have installed and I found that the one that comes with Colonist A514 (free app from the store) works!
Specs: AMD Ryzen 9 5950X, Corsair H150i Pro XT, 32GB Corsair Dominator RGB 3600MHz, Asus ROG Strix X570-E Gaming, Asus ROG Strix 3080ti, Corsair HX1000, Western Digital SN850 M.2 NVMe 2TB, Samgung 850 EVO 500GB + 840 EVO 500GB in raid0, Seagate Ironwolf 10TB, Corsair 4000D Airflow, Asus PB287Q 3840x2160 @ 60Hz, Samsung SyncMaster 226BW 1680x1050 @ 60Hz. Oculus Rift S, Oculus Quest 2 64GB.

surgeman13
Level 2
Does this still work for anyone.  I tried replacing the OVRPlugin.dll using the one supplied by Shrimp24201, but it gives me an "Entitlement Check Failed" error, and doesn't load.

shrimp24201
Level 2

OK, here we go again.  You can read the whole story or jump to the workaround.


whole story:  I recently got the itch to play this again, got the entitlement error now, and its no fun.  So contacted Oculus support as I own the game, why can't i play a game i own?  They gave me the advice to reboot, restart, reinstall, but it did not fix the issue.  They said contact the developer Gunfiregames, I contacted them, they said Oculus supports this game ... Arrgh..  Anyhow, I did some searching and finally found a workaround and solution to get the game running again.  Its not pretty, and I'm gonna keep posted in Oculus forums and voice about this... I mean, I have older DOS / win98 stuff and can run games which I own with the proper setup.. but Oculus forces you to update all the time and stuff breaks.. and that is annoying. It would be nice if we could downgrade the sw / hw firmware if necessary.  Below is the solution I found after some digging.

Workaround:  Search for this online.  (FIXED - Old Oculus Home Runtime W/ Instructions) Follow the instructions and you can run the game again.  I did not do that post, but thankful to the person that did their old software homework and made a backup, I was planning to backup my older machine folder and try (see next sentence), but tested this solution and it works again on my new machine. ( I also noticed on an older machine with older Oculus software that I only needed to replace the DLL from my previous post).  However now I'm safe with this backup as long as it doesn't break again.  One other tip, after following the instructions and you have the older runtimes go to your oculus game directory and find the Software Ex: Oculus\Software\gunfire-games-llc-herobound-spirit-champion\  and double click to run the HeroBound2_PC.exe and it should work! Hope this helps someone who wants to play this fun game!