cancel
Showing results for 
Search instead for 
Did you mean: 

Game fails to install.

Zeelophone
Level 3

I paid a solid amount of money for the game 'Creed:  Rise to Glory ' so that I could play with my friend. I was excited to play it, until I realized it wasn't installing. I was upset to find this in my notifications: 

Zeelophone_0-1618264082119.png

I've tried all kinds of remedies. I've restarted my pc, I've restarted oculus, I've swapped the download folder, I've used task manager to force close all oculus applications, I've tried installing on the betas and not on the betas. I purchased the game with my Rift  S in my oculus home, so I see no reason why it would've purchased an incompatible version.

I use windows antivirus, and I don't think I'm having any antivirus issues, as I get no notifications about blocking a threat and I've checked the protection history and it doesn't mention oculus. I'm frustrated with this, I've seen posts dating as far as 3 years back yet this mega corporation can't fix a simple issue in the store. Outrageous!

Please may somebody help out?

2 REPLIES 2

lucfier666
Level 2

I am having the same issue i have tried it all but no luck 3 hours straight of trying to download asgards wrath

 

OculusSupport
Oculus Community Manager
Oculus Community Manager

Hello @Zeelophone & @lucfier666  If you haven't already please submit a ticket with us and include the log files from your system so we can review them and try and determine why the install fails. Thanks!