cancel
Showing results for 
Search instead for 
Did you mean: 

Having Oculus Rift Setup issues? The ultimate guide.

LZoltowski
Volunteer Moderator
Volunteer Moderator

Heya, so after a few years on this forum and helping what must be a hundred people now with their issues I have compiled a few checklists and tips on how to get your Oculus Rift installed and working. This list is by no means exhaustive but might help.



 



Pre-Installation checklist:



Disable Antivirus/Anti Malware



Although not every antivirus program will block the setup, many like BullGuard and MalwareBytes are very sensitive to any system changes, remember, this is not like installing a game. The app needs to create services, a special windows user, firewall rules, permissions etc to function properly.


Bullguard is also known to block the setup’s ability to connect to Oculus servers. Unless you know how to properly configure inbound/outbound rules and other settings, disable or uninstall the antivirus during the main setup. I know it's a pain but it accounts for 90% of setup issues. Some users have reported that only by completely uninstalling Bullguard the setup will complete.

Also to note BullGuard is known to prevent the proper operation of the Oculus App after setup, it can prevent games from installing, even if added to the exceptions list.

If you don’t have antivirus installed you are probably using windows built in Defender, disable that temporarily during setup (including protected folders)




Make sure you have at least 60GB free on the system drive and that the drive is NOT a dynamic drive



Although after installation the Oculus App measures at roughly 11GB, it needs the extra space to complete setup procedures, such as uncompressing of files. So even though 14 is recommeneded by the setup, let's be on the safe side.



If you wish to install to a drive other than the setup drive please follow these instructions
https://support.oculus.com/1142129705828091/

Note: As with most software setups on windows, installing to a drive other than C will still result in some data being installed on C, esp in either Document and AppData folder.



Unplug any non-essential USB devices during setup



The Rift can draw quite a bit of power over USB, to avoid any issues with no image during setup unplug any USB devices that are not necessary, basically keep everything to a minimum. See some troubleshooting tips below. 




Make sure you are running as clean session of windows as possible



Some people experience issues during setup while windows is running background applications such as:



  • Motherboard Utilities eg Asus AI
  • GPU tweakers
  • Any CPU/GPU monitoring apps (these are also known to cause micro stutters while in VR)
  • SSD Utilities such as Samsung magician
  • Any third party windows explorer shells
  • Third party utilities like keyboard app etc
  • If you have Windows User Policies set up make sure there aren't any restrictions for the current user
Basically absolute minimum (a sort of Windows Safe mode but not, actual Windows Safe mode will not work)








 



Make sure you are up to date!



Make sure you have all the updates installed such as:










Some ISP’s cache the setup files



Some ISP’s are known to cache the setup files the software is trying to download, this can cause the “chunks” to become corrupted and prevent the setup from completing. I have seen this in New Zeland and Australia, in such a case using a VPN and connecting to a country next to you solves the issue.



 



Do not run the setup file by forcing it AS ADMIN, this will cause issues



 

Common workarounds:



What if nothing works and I cannot get Setup to start the “Setting up your Rift” portion?



Several users have found out that their Windows User profile is the culprit, as an experiment, it is a good idea to create a new admin windows user, make sure it is a LOCAL user, not one associated with your Microsoft cloud login and try and run the setup from there.




I have followed ALL the checklists but the setup gets stuck at the end
If you REALLLLLLLLLLY did all the checklists and still no go, you may try this method several users have found to work
https://forums.oculusvr.com/community/discussion/69245/oculus-software-sorry-we-encountered-an-error...




What if my Rift is not being recognised or I am not seeing an image (but I get sound) during setup:



Try moving the USB connections around, for example, move the sensors to USB 2.0 ports and leave the Rift in USB 3.0 .. you might not have enough power coming in through your USB ports.


Try plugging the rift via a DisplayPort using a dongle.


Unplug any secondary monitors you have.


Make sure you are not running any screen streamers or remote desktop software in the background

Try a downgraded version of the GPU drivers such as: 
https://www.nvidia.com/download/driverresults.aspx/127667/en-us



 



For Laptops: Many laptops are incompatible with the rift, this is because the HDMI port is wired to the Intel CPU, and not to the GPU and/or not enough power is being delivered through the USB ports.



Known possible workarounds are:










Getting more help:

If you have tried all the above and are still unable to install please contact Official Oculus support:



https://support.oculus.com/



It may be a good idea to collect your logs and attach them to your ticket.
Here is how to do it:
https://forums.oculusvr.com/community/discussion/33792/how-to-get-logs-for-bug-reports-for-consumer-...

If you have any more to add please do so bellow and ill compile them in.

Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

Be kind to one another 🙂
45 REPLIES 45

italoschiochet
Level 3
these is my problema. i reinstall , sensors, touch, ok, usb ok, but no hdmi conection? I paid a lot of money , and now dont have solutions for this problem? im from Brazil. What i do?0vns2njx030t.png

jsteamid
Level 3
I just bought a new SSD 500gb and migrated everything successfully, since my Oculus installation was on my other drive I want to reinstall it to my new SSD, then I uninstalled Oculus, but when I try to reinstall it says :
Sorry, we encountered an erroor during installation. Please restart your computer and try running Oculus Setup again. bla bla bla...

----

Turned out it's my fault, C:\Program Files\Oculus was junctioned to drive D , deleted the junction and it's installing fine.

LuVille89
Level 2

Hi, good
afternoon, I’m having trouble starting the oculus.exe, since the Rift Core 2.0
beta has been installed (before the oculus was working perfect), I get the
message “OVRServer_x64 … has stopped working”, and if I attempt to start the
program I get “We’re having trouble starting oculus” error. I have tried repair
and uninstall the software but that doesn’t solve the problem. Do you have any ideas what is causing this? By the way I have windows 7.

dsdcuqxfhux7.png

mhb1q7u63cip.png



Many thanks
in advance.








Rahotep
Level 4
I am unable to launch the Oculus Suite. I just installed for the second time. Fresh. Deleted all references to Oculus Home and Dash in my users data folder.

Rift Senors can be found in the HW list
HMD is not being seen
HMD Audio is OK
HMD orange light is on
HMD is being recognized when launching SteamVR and tracking is working. LED turns white, but no video is being displays. HMD remains dark
NVIDIA Control Panel does not see the VRDesktop. It used to have one before I repaired the Oculus Suite
Oculus Home stays on the loading screen, turning and turning

Meanwhile I deleted the Oculus Apps from the Apps drive too 250 GB gone

Any different? No

Cannot load the software piece any more nor log in


MAC_MAN86
Level 9
Install Issue - OCULUS UPDATE 1.32 BLOCKED MY XEON which is more than capable.
This is corruption!

KNP54
Level 5
This is a bit technical, but interesting read:
https://blog.exxactcorp.com/active-vs-passive-displayport-adapters-what-you-need-to-know/
Basically it says that if you're out of HDMI ports and have Rift + Multiple Monitors, you probably need an ACTIVE Display Port to HDMI for your setup to work!
Specs: Delidded i7-8086k @ 5.0 GHz all cores, NZXT X52 cooler, 32GB G.Skill 3200MHz, ASRock Z370 Gaming-ITX/ac, Asus GTX 1080 Strix, Corsair SF600 platinum, Samsung 970 EVO M.2 NVMe 1TB, Samgung 850 EVO 500GB + 840 EVO 500GB in raid0, Seagate Ironwolf 10TB, Louqe Ghost S1, Asus PB287Q 3840x2160 @ 60Hz, Samsung SyncMaster 226BW 1680x1050 @ 60Hz. Oculus Rift S.

elijah_selenius
Level 2


these is my problema. i reinstall , sensors, touch, ok, usb ok, but no hdmi conection? I paid a lot of money , and now dont have solutions for this problem? im from Brazil. What i do?0vns2njx030t.png


i have the same issue but i cant find any help

sford52
Level 7
Thank you @LZoltowski , this is an extremely useful thread. I would like to offer some unasked for and possibly unwanted suggestions:
If you are having issues, please don't append them to this thread, rather start a different thread with regards to your specific issue.
If you are having issues, please be sure to include details about your computer: desktop/laptop, brand and part number, mobo, cpu, gpu, OS, GPU version
It's really really hard to help folks resolve computer issues without knowing about their computer.


Specific issues:
1) Regarding SLI: I dont think Oculus works in systems with multiple GPU's.
2) I dont think Oculus works with Win 7 anymore.  It may be only Win 10.
If you had and issue and have resolved it, please append your solution to this thread
ASUS ROG Strix GL702VS-AH73 17.3" Laptop.  I7-7700HQ, GTX1070, 12 GB DDR4 RAM, 500 EVO 970 GB SSD, VS 2017, Oculus rift, Windows 10 home

tjwestie
Level 2
8uh8af50c3hg.png