cancel
Showing results for 
Search instead for 
Did you mean: 

Help!! Rift dead on arrival with one blank, one corrupted display..

noknees
Level 3
Hi guys

I'd love some help here.. My Rift arrived last week and I cant get it to work. 

Upon installation of oculus home, I get through the connection routine with no issues, but once the rift activates the proximity light changes from orange to white but I get one blank screen and one screen full of green streaks. If i power down or disconnect then try again I then get two blank screens. 

Helpfully the oculus software then strands me at the adjust lenses section with no way to escape except to uninstall all traces of oculus software using a third party uninstaller and start again.

My system is:

i7 4960x @ 4.4ghz
asus rampage extreme IV mobo
radeon 295x2
win 7 64bit

so far I have tried all display ports with a mini dp to hdmi adaptor and the dvi port via an adaptor.
I've also installed the recomended inateck pci-e usb card in an effort to eliminate possible usb issues and have done all the obvious stuff like re-seating the cable but still get the same result.

I've opened a support ticket and have had a few responses and have provided logs, but it's now gone quiet and they haven't responded for a few days.

Does anybody have any advice on the best course of action?


grxfh6k3qfvh.jpg



og83o76baai2.jpg
11 REPLIES 11

Hiro_Protag0nist
Level 13


Same happened to me ordered the HDMI as above.. Praying mine starts working. Just hope it fits in the AMD R9 295x2 Mini Display ports.....


@ctansley69

Hi, did it work - would be really useful for others who have the same problem.  Cheers!

SkateZilla
Level 5


Same happened to me ordered the HDMI as above.. Praying mine starts working. Just hope it fits in the AMD R9 295x2 Mini Display ports.....


it will fit,
But whether or not your R9-295x2 has DualMode Display ports is another story.

I have yet to find a passive adapter that works on my Overclocked 7970s.
*They all Run DisplayPORT 1.2 w/ MST Support and Minimum HDMI 1.4a.

I bought the Full DP one and tried it with an Full to Mini Adapter, and got no signal at all.

the Mini to Full adapter may or maynot have goofed the pin/lanes for dual mode.