cancel
Showing results for 
Search instead for 
Did you mean: 

Help wanted: How to start SteamVR without Oculus Home?

hoppisoft
Level 2
I need your help guys:

I would love me some extra fps for SkyrimVR, so i decided to try to set the OculusClient.exe to "start as administrator", which works great for preventing Oculus Home to come up each time the sensor on the Rift ist blocked.

Now i start SteamVR directly and the Oculus HMD is recognised and is tracking correctly, but i get no picture in the Oculus itself. Once i start Oculus Home itself (which i was hoping to avoid) all is working fine again. Am I doing something wrong or in the wrong order?

1. OculusClient.exe is set to "start as administrator"
2. I start up the Steam Client and start SteamVR manually from there
3. I put on the Oculus

anything missing? Your help would be greatly apreciated 🙂
9 REPLIES 9

WreckLuse68
Level 7
I do everything that you do except I don't start SteamVR...I just run the games directly from my Steam library as I would normally.
Some games you can put a command line argument like '-othervr' or something like that...some games give you an option for Oculus or Vive when they launch if a headset is detected...some just work.
I don't have Skyrim so I cant say for sure.
Good luck.
When Einstein was asked how it felt to be the smartest man on Earth, he replied, “I wouldn’t know. Ask Nikola Tesla”.

Chazmeister
Level 8
hoppisoft said:


anything missing? Your help would be greatly apreciated 🙂



You need Oculus Home to running in order to use the Rift. That is why Steam VR starts it up automatically. So I'm afraid you'll have to find some other way to boost your frame rate. I think the background usage by OH is pretty minimal once you're in a game anyway.

LuluViBritannia
Level 9
Sadly, Oculus blocked this solution. I tried to contact the Support but they would just imply that it comes from my rig (my VRAM is not enough for VR, so officially my laptop isn't VR-ready, and Oculus just doesn't even try and help you when that's the case).
I'm pretty sure the problem occurs for everybody, but for now I can't prove it (I will have the chance tomorrow).

That said, Skyrim VR works quite well even with Home on. You should try it ^^. Also, you can disable Steam Dashboard to loosen your GPU a bit. It's not a big gain, but it can still make your game smooth.
Hyped for the Quest 2!


My hopes for VR next gen:
- Full Body Tracking. Come on, Oculus!
- Eye tracking with foveated rendering. Must reduce the power needs!
- More big-scale games. I need a true VRMMORPG!
- Bigger community.

"If you don't mind, do you want me to take you there? Where dreams come true."

WreckLuse68
Level 7


hoppisoft said:


anything missing? Your help would be greatly apreciated 🙂



You need Oculus Home to running in order to use the Rift. That is why Steam VR starts it up automatically. So I'm afraid you'll have to find some other way to boost your frame rate. I think the background usage by OH is pretty minimal once you're in a game anyway.


I run many games quite happily from Steam without needing Oculus Home, or the Steam equivelant, running at all...The only time I have Home running is when I want to launch something from the Home Library.
If you set the Oculus Client to 'run as admin' then Steam wont start it automatically...as the OP has already stated.
When Einstein was asked how it felt to be the smartest man on Earth, he replied, “I wouldn’t know. Ask Nikola Tesla”.

Boneboys
Level 4

If you set the Oculus Client to 'run as admin' then Steam wont start it automatically...


Not so since the last Oculus build.
Oculus client must be running to play games through Steam, otherwise you will find nothing more than a black screen.
Forced startup parameters such as /othervr do not work.
I'm informed it was so during beta testing and carried through to public release (version 1.26).
I've tried a few workarounds without success.

Just to make things worse when Oculus is closed after playing a Steam game I find myself with a broken taskbar on monitor 1.
I've tried several work arounds (unplugging 2nd screen), however I believe I have found a hotfix by going into taskbar options and switching the auto hide on/off tab.

It appears that Oculus are forcing Oculus Home to be running in order to play other games.

Get a Grasp, get a Grip, get Rifting.

WreckLuse68
Level 7
Ah ok...I am on the old Oculus home not the beta and I can still launch without either being open...I think I was getting other probs with the beta and steam which is why I use the old version.
My apologies.
When Einstein was asked how it felt to be the smartest man on Earth, he replied, “I wouldn’t know. Ask Nikola Tesla”.

Boneboys
Level 4
NP.
Tested with DCS, PC2 & The Forest, the solution to the problem was to be found here...
Marc-G said:
I acutally found the reason why; the 1.26 Update automatically turned On the Rift 2.0 Core Beta opt-in option by itself, I never changed this previously. Turning this back to Off and the "Run As Admin" works again, quite why Oculus decided to force that to On for an update is a little annoying though.
Get a Grasp, get a Grip, get Rifting.

ItzGavin
Level 2


 I think the background usage by OH is pretty minimal once you're in a game anyway.

I know by experience that OH has a very large impact on games when running heavy games on a low end pc. I know this because I have a 660ti and have gotten around every loophole... now being able to play games like skyrim at 90 fps... in vr!

sraura
Level 7
google oculus homeless