Showing results for 
Search instead for 
Did you mean: 

Hmd Tracking Stutters with more then one sensor

Level 4

I've been having a strange problem since i got my touches in, whenever im using more then one sensor my hmd tracking jumps when turning around with my back to the cameras.

I dont run into this when using just one sensor. I can turn around and the tracking is 100% solid, but the moment i plug sensor two back in the tracking jumps when i stop with my back to my sensors. This shouldnt be happening with the hmd I would understand if it was the controllers but the Rift has tracking lights on the back of it.

I've tried using every combination of usb ports and sensor placement, from up high on the ceiling to just on my desk still the problem remains. I even borrowed one of my buddies cameras to run the experimental setup, the irony is that the controllers track great with the three cams in roomscale but the hmd does not. Playing something like jobsim on steam I will turn around to grab something and the whole world shakes like someone is bumping my sensor.

I've spent the last two days trying everything I can think of but still nothing helps other then using just one sensor. The last thing I can think of trying is buying a usb card and see if that helps. Sorry for the wall of text but I've been beating my head against the wall trying to smooth out the hmd tracking just a little frustrated at this point.

151 REPLIES 151

Level 4

Thanks for sharing the logs. This will help us get to the root of the problem.

Cool,, heres mine too if it helps,, although I get the same issues with 3 sensors I'm just using two for now to quickly try 360 tracking in SS:First Encounter (Great game btw).. Same "Poor tracking warning" using the supplied extension lead, I normally have two sensors in USB 3.0 and one in USB 2.0 as your guide says and get the same message in home after a jittery session lol..

I've tried all sorts of combos with USB ports etc and I just get the same problems with tracking and the same warning no matter what sensor I use on the extension lead, So I have ruled out a faulty sensor, at a loss now but I can see the grass is defo greener when 360 tracks perfectly for that short but brief moment...     

Level 4

SuperTuck said:

Yeah, but they have had an extra eight months to iron this out before launch. Losing a bit of faith right now.

There's a good chance they will figure out some fixes to correct a lot of the issues, but it may take some time.  The Touch in the wild along with three sensors is still a new thing for them.  That being said, given Facebook's, ahem, liberal data collection policies I am amazed they haven't been pulling good information on everyone' setups to help triangulate on the issues.

Level 5
Ive just tested my controllers with only one sensor plugged in.. they work but somehow i still get the same tracking issue with the hand either floating inwards slightly or warping around if i get to about 2 metre away im wondering of some led lights or some shiny thing in my room is causing this? 

Level 3
I also have this vertical tracking issue.  Sometimes I'll snap up but not back down.  I'll be ~8 inches taller at least until the tracking issue is triggered again.  This puts objects on the floor out of my range as I hit the real floor before the virtual one.

This issue is reproduced reliably for me within a minute of starting "First contact".  I've tried many things to resolve, got the pci-e USB 3 card, tried different sensor positions, re-calibrated, etc. but it still plagues me.

Logs attached.

Level 4
Was hoping to demo the Oculus and Touch to the family when they come around for Christmas. Any ETA on the Oculus Home update to resolve this issue?

Level 5
So should I pack up the Rift and Touch and just start using the Vive again?  I really can't believe how bad the tracking is when compared to the lighthouse solution...

Is this something that we can expect to be resolved?  I'm doubtful since support just keeps asking people for logs, and if they actually knew what the problem was then they wouldn't need feedback from us PAYING beta testers...

What a joke.

Level 2
I'm getting the same issue, no problems when I had one sensor,. When I got touch and a second sensor it started happening a bit. Now with a third it happens pretty often. I can see the same snapping up and down as in the videos here. In between the glitches tracking is basically flawless. It definitely seems to be related to some sort of sensor 'hand-off' as I can pretty reliably trigger it by facing and moving towards a different camera such that maybe the 'preferred sensor' (if there is such a thing) would change.

It is a shame around Christmas as I was hoping to blow my family's minds as they're over tomorrow, but this brings it from the realm of magical to the realm of an amusement that is still too glitchy to be properly immersive. 😞

Level 2

HoIIywood said:

BCL74 said:

@cybereality some say it could be an issue with imu calibration, is there a way I can get the tool to check, or does that seem incorrect? 

In Oculus Home at the top choose the cog wheel, then goto Settings.
On the new page, select Devices and there's a 'Configure Rift' drop down menu where you can choose to Reset Sensor Tracking. This will check your connection and sensors are healthy.

If you want to do the room layout/Guardian again, then in that same drop down select Guardian System

In this thread:
there were several people had success running Full Setup, rather than Reset Sensor Tracking, to fix tracking issues involving tracking and upside-down cameras. I was having the same problems I'm seeing described here, and looking at my logs I also see "Too much camera movement" entries. I spent several hours trying to isolate usb and other hardware issues and reset the sensor tracking dozens of times. In the end, running Full Setup instead of Reset Sensor Tracking made everything work, though it still makes no sense to me that it should.

Level 2
Make sure when set up tracking for 3 sensors that you put the controller above your head instead in front of your face so all 3 sensors can see it .

Level 2
It worked for me after 3 days of stuffing around trying to get it working properly.