cancel
Showing results for 
Search instead for 
Did you mean: 

Hmd Tracking Stutters with more then one sensor

Gravity1368
Level 4

I've been having a strange problem since i got my touches in, whenever im using more then one sensor my hmd tracking jumps when turning around with my back to the cameras.

I dont run into this when using just one sensor. I can turn around and the tracking is 100% solid, but the moment i plug sensor two back in the tracking jumps when i stop with my back to my sensors. This shouldnt be happening with the hmd I would understand if it was the controllers but the Rift has tracking lights on the back of it.

I've tried using every combination of usb ports and sensor placement, from up high on the ceiling to just on my desk still the problem remains. I even borrowed one of my buddies cameras to run the experimental setup, the irony is that the controllers track great with the three cams in roomscale but the hmd does not. Playing something like jobsim on steam I will turn around to grab something and the whole world shakes like someone is bumping my sensor.

I've spent the last two days trying everything I can think of but still nothing helps other then using just one sensor. The last thing I can think of trying is buying a usb card and see if that helps. Sorry for the wall of text but I've been beating my head against the wall trying to smooth out the hmd tracking just a little frustrated at this point.

151 REPLIES 151

MrPark94
Level 4

BCL74 said:

@cyberreality I really think this is a usb issue. I mentioned I moved everything to another computer and the issue subsided. The thing is, when I switched the USB ports on the 2nd computer, the issue came back. When I moved them back to the ports they were at, HMD and 1 sensor directly into the MB and the 2nd sensor on the front panel, the issue subsided again. Obviously this is anecdotal, but trying out multiple setups and multiple computers, it seems very dependent on which ports each is plugged into...


I have been struggling with sensor issius from day one..so sick of it.. 
on day one when the rift launched with one sensor on the reccomended inateck card.. after trying everything the problems went away for a couple of months.
the i bought touch and a third sensor, the sensor problems started again... i now have the 2 front sensors in the inateck card.the 3 rd one in a usb 2.0 slot in my moba..and the hmd in a 3.0 port on my moba. (x79 asmedia)
this works for a while.. and then the sensor problems on the 2 sensors on the inateck card..act up again.. to the point the rift is unusable. i have my 2 sensors connected to recommended  5M active cablematters cables..
my drivers ae up to date..literly tried everything here on the forums.. but the problems still return.
thee are lots of people experiencing this problems.. and still no solution from oculus.

MrPark94
Level 4
i tried to sent a log file.. but when i lolk here C:\Program Files (x86)\Oculus\Support\oculus-diagnostics

there is no oculus folder to be found.. only on normal program file folders.. but there is no 
OculusLogGatherer.exe

to be found

MrPark94
Level 4

Mnem0nic said:



Thanks for sharing the logs. This will help us get to the root of the problem.


Cool,, heres mine too if it helps,, although I get the same issues with 3 sensors I'm just using two for now to quickly try 360 tracking in SS:First Encounter (Great game btw).. Same "Poor tracking warning" using the supplied extension lead, I normally have two sensors in USB 3.0 and one in USB 2.0 as your guide says and get the same message in home after a jittery session lol..

I've tried all sorts of combos with USB ports etc and I just get the same problems with tracking and the same warning no matter what sensor I use on the extension lead, So I have ruled out a faulty sensor, at a loss now but I can see the grass is defo greener when 360 tracks perfectly for that short but brief moment...       

Same here.. 2 bat=d tracking errors on the inateck catd.. i use 2 active 5m extension cables from cable matters.. only thing that helps is unplugging and reinserting them.. then it works fine for a couple of hours..sometimes days..and then it acts up again.

Flausn
Level 5
fix this its a shame !!!!! and annoing !!!!!

rabbitovsky
Level 2


So should I pack up the Rift and Touch and just start using the Vive again?  I really can't believe how bad the tracking is when compared to the lighthouse solution...

Is this something that we can expect to be resolved?  I'm doubtful since support just keeps asking people for logs, and if they actually knew what the problem was then they wouldn't need feedback from us PAYING beta testers...

What a joke.


I would advise playing with the Vive until they fix this.  It's a completely fixable software-side glitch that somehow must have never gotten picked up by QA.  I imagine there will be a fix in he next couple weeks and agree with a previous poster that it's a shame it happened around Xmas.

For what it's worth, tracking has been damn near flawless with 1 sensor, and was perfect (minus occlusion from behind) 180' with 2 sensors.  The moment I got a 3rd sensor, used extensions, downloaded fresco drivers....well, the whole system went off crap.

Its embarassing, but I bet within a month it will be fixed and nobody will even care.

rabbitovsky
Level 2
Btw, I decided to heed what some of the others in here were saying, and uninstall fresco, go back to two sensors, plug the sensors in my mobo 3.0 outlets and my headset into my (apparently buggy?) inatek 3.0 expansion (where I get a warning sign that I need to update my drivers in the set up screen), and keep the sensors on my desk with the same pivot.

Zero tracking issues, outside the 180' occlusion.

Plugged my 3rd with included extension into a mobo 2.0 outlet, same height, in recommended experimental set up, same pivot--minor hiccup issues, but 99% occlusion free.

Fix this stupid software issue Oculus!  We are so close! 🙂

coderzero
Level 3

MrPark94 said:

i tried to sent a log file.. but when i lolk here C:\Program Files (x86)\Oculus\Support\oculus-diagnostics

there is no oculus folder to be found.. only on normal program file folders.. but there is no OculusLogGatherer.exe

to be found


Try :  C:\Program Files\Oculus\Support\oculus-diagnostics

MrPark94
Level 4
thx that worked

Dibelabbes
Level 5
Any news on that, Oculus?

R0cksteddie
Level 4
I posted in a similar thread which is basically the same issue where my HMD stutters when turning around which started when I added my second sensor with Touch.  I get the occasional height glitch but I'm getting more of a millimeter sideways glitch (hard to describe) where the whole image shifts.  I attached my logs in the other thread and was told one sensor seemed to be timing out (getting lots of Frame Truncated Errors) and to try in a USB 2.0 port.  Well of course I tried both sensors in a USB 2.0 port and it made no difference what so ever.  I've added a powered USB HUB, swapped ports 3.0 and 2.0 again all had no effect.  This is with all the usual updating drivers, changing USB power settings in Windows 10 and I also bought an Inatek card I haven't installed it as I really don't think its a USB bandwith issue due to the next paragraph.

In the end I decided to try and go back to one sensor which happened to be my new 3rd sensor that turned up yesterday so brand new, and to my horror I'm getting the same glitching with only one sensor and it was quite bad.  I hadn't restarted the PC after re-running the set-up and changing camera's mind you.  I'm really at a loss now, it cannot be my PC as it worked flawlessly when I first used the rift as nothing hardware wise has changed so now I'm thinking it's either the HMD itself that is faulty or it's just been caused by a change/update in the Oculus software.  I can really only hope it's the latter and that some update will be provided soon!!