Showing results for 
Search instead for 
Did you mean: 

Hmd Tracking Stutters with more then one sensor

Level 4

I've been having a strange problem since i got my touches in, whenever im using more then one sensor my hmd tracking jumps when turning around with my back to the cameras.

I dont run into this when using just one sensor. I can turn around and the tracking is 100% solid, but the moment i plug sensor two back in the tracking jumps when i stop with my back to my sensors. This shouldnt be happening with the hmd I would understand if it was the controllers but the Rift has tracking lights on the back of it.

I've tried using every combination of usb ports and sensor placement, from up high on the ceiling to just on my desk still the problem remains. I even borrowed one of my buddies cameras to run the experimental setup, the irony is that the controllers track great with the three cams in roomscale but the hmd does not. Playing something like jobsim on steam I will turn around to grab something and the whole world shakes like someone is bumping my sensor.

I've spent the last two days trying everything I can think of but still nothing helps other then using just one sensor. The last thing I can think of trying is buying a usb card and see if that helps. Sorry for the wall of text but I've been beating my head against the wall trying to smooth out the hmd tracking just a little frustrated at this point.

151 REPLIES 151

Level 3
I have all these exact same troubles, after hours of plugging and unplugging, reinstalling, driver rollback, driver updates, I fixed it for me at least. I had a 5-port inatech card before, I just ordered and installed another inatech card, this time the 4 port one. I also saw that inateck had a newer driver (August-16) which I got from here:

 I I put the HMD alone on the 4-port one, I put the two USB3 sensors on the 5-port one, and I put my 3rd sensor on my motherboard at USB 2.0. All problems disappeared. While it could be related to trying the new driver, I will now stay convinced that it is a USB bandwidth problem. They may be able to get a fix through software by locking camera rotation, since that is actually what is happening, but at least I can sleep at night now. Hope it works for you too.

Level 9
1. Are you sitting down when you perform the Sensor Scan? It could be necessary to do as it requests and Stand Up as it may already be taking into account your set height even if you will be sitting down mostly.

2. Windows 10 Updates triggers off resets in Device Hardware. e.g. It will Enable Sound Drivers and it's Profiles which were once Disabled and Hidden. It may eventually tell you about it having issues with these. It also does reset your USB Power Management choices. You may need to disable unused Sound Drivers (e.g. Monitor or onboard Sound if using a card). I always never install Nvidia extras - just the Driver and nothing else at all. I can still access the 3D Panel without Experience to set Dynamic Range = FULL.

3. In adding new USB devices you may need to clear the existing memory cache which it has gathered for those Ports by using either the Scan Hardware Changes on the actual USB Hub tab in Devices or the holding power button for 30mins while off and unplugged >see here: -

4. The Redistributable C++2015 may have become corrupted by the Win 10 Update (mine was) and you either select Repair (within Uninstall Programs) OR remove it and Oculus Home and let it install this for you again. The latest Update of this file could be bugged. It was the (x86) version which seemed to cause stutters to mine on my 64bit Win 10. Oculus Home needed these both removed to allow it to install the (x64) version again.

I must use ASW OFF and the binds still work. It is much as it once was but with slightly lower latency so I may try option 3 next myself.