cancel
Showing results for 
Search instead for 
Did you mean: 

How do I register my Rift S to my account?

Error-401
Level 3
Hi purchased and setup a rift s yesterday, logged into my oculus account today and I noticed I have no registered devices.
How do you register the device? Is this done whilst you are viewing in the headset? If so where abouts is the option?

Many thanks
PC: Intel Core i9-9900K | Corsair Vengeance DDR4 3200 16GB | MSI RTX 2080 Ventus | Samsung 970 Pro NVMe | SilverStone SX700-LPT | GIGABYTE Z390 I AORUS PRO WiFi | SilverStone RVZ03B-ARGB

20 REPLIES 20

CaptCookie
Level 2
I am having the same issue too.  How do I register it to my account

Error-401
Level 3
I was able to create a support ticket by going to https://tickets.oculusvr.com/hc/en-us/requests/new however you don't seem to be able to login into that portal once you have created the ticket. It doesn't accept the creditials that you use for the main site, which is weird. Anyhow they emailed me back and said:

Thank
you for contacting Oculus Support. I see that you are looking for more
information on why your Device has not shown up in the Web based
account. I can certainly assist you with this information.

Under
the "My Devices" section it may take some time for your headset to
register. But rest assured it will link your Rift-S with the Website.

Which is a bit pants given your payment details and store purchases sync straight away....
PC: Intel Core i9-9900K | Corsair Vengeance DDR4 3200 16GB | MSI RTX 2080 Ventus | Samsung 970 Pro NVMe | SilverStone SX700-LPT | GIGABYTE Z390 I AORUS PRO WiFi | SilverStone RVZ03B-ARGB

RattyUK
Level 10
Mine doesn't exist on the Oculus page either 🙂
No great shakes, the desktop store works just fine  - maybe there is an unresolved issue in porting the Rift S infor to the site.
PC info: AMD Ryzen 7 2700X, MSI MPG X570 Edge, 16GB Tforce Pro Dark DDR4 3200, KFA2 RTX 2080 Super, Samsung 870 Pro M.2, 2x 240GB SSD, 3TB WD Green HDD & 4 TB Seagate Barracuda HDD, Antec Modular 750w PSU, custom watercooling loop. (Win 10 Pro & Opensuse Leap 15.1 Linux) 32" AOC 4K Monitor.
Rift S
Laptop: Aorus X5 V6-CF1 (I7-6820HK, GTX 1070, 2* 256GB M.2 NVME, 1TB 7200 HDD)

Lange_666
Level 3
This still isn't solved.
Under My Devices i read this:
An Oculus device isn't registered to your account right now. Set up an Oculus headset to get started.
And then what? I looked through the support pages...nothing.
Also, if i check My Rift then it show my headsets serial number.
Maybe a device is something different then a headset?

ashiyawolf
Level 2
Same here. My Rift and Rift S don't show on my web account, although they show up in the Oculus app itself under devices. Considering I've had the Rift for over a year, it definitely is more than it just "taking some time" to update.

Gobblehunter
Level 2
Come on Oculus, what's going on?

ElPappa
Level 2
Has anyone figured out how to register device? 

givan
Level 2
I am having the same issue. My Oculus rift s was setup successfully and yet it doesn't show up under devices not allows me to register a new one. Anyone found a solution? 

Twodogsprime
Level 4
Ive had my rift for years  now CV1 and mine doesnt show up in my devices , a couple of tabs up it shows my serial number though . It hasnt affected my usuage in any way , i can buy content either in my store or online.