cancel
Showing results for 
Search instead for 
Did you mean: 

I'm done! I give up!

Robot_Isnt_Real
Level 3

I've tried literally every single dang performance issue fixing method there is! It just won't work! I had literally no lag before but it just suddenly pops up giving me awful 6 fps lag spikes every 5 seconds which last 7 seconds!

 

The last thing I am trying is the official cable, and if that doesn't work I will take LITERALLY ANY suggestion.

But for now, I give up. VR used to be the only thing I have fun with but now it is horribly annoying just trying to boot up the **bleep** thing.

 

Just, try to tell me what I can do now before the cable arrives.

1 ACCEPTED SOLUTION

Accepted Solutions

@Robot_Isnt_Real  OK mate I'll try to give you settings that I think should give you the best PCVR results with your laptop PC using Link.

 

Oculus desktop pc app settings;  General tab make sure to select Oculus openxr as default runtime.  Device settings 80Hz refresh and 1.0x res slider.  Also, make sure your on the latest stable version (currently v42), not beta (currently ptc v43).  Run the Link usb speed test and make sure you are getting at least 2.0Gbps, preferably a little better.  One problem with Laptop usb ports is that they do not always supply enough power so sometimes a powered usb hub is a good idea.  Also, laptop usb ports have limited bandwidth so try to minimize the number of usb devices connected at any one time.

 

Oculus debug tool settings; set everything to default/zeros/auto except Distortion = Low, Encoding Bitrate width = 3664. Bitrate = 300mbps, Link Sharpening = enabled, mobile asw = disabled.  Make sure to restart oculus runtime services after making these changes.

 

Nvidia; use the latest 516.59 driver (best right now for rtx2000/3000 series gpu's imho) and use DDU to uninstall previous drivers beforehand (google how to do this).  Only custom install driver, physx, and HD audio drivers (do not install geoforce experience).  Nvidia 3D Global settings; with a laptop I think the top option should = prefer using the higher powered nvidia gpu (not your integrated igpu), everything else Defaults except Power = prefer max performance, below that change Quality default to High Performance.  Press the Apply button to save these.

 

SteamVR settings; set all Visuals Manually (not auto) to 100% and disable advanced super sample filtering.  Also, opt into SteamVR Beta (currently 1.23.6).  There have been some nice Q2 related improvements.  Go to your steam desktop library and right click on SteamVR, then properties, then beta, and select opt into beta.

 

Windows 10 settings; disable Hardware acceleration graphics (HAGS) and turn off Game Mode.  Also, go to your win10 power settings and select the high performance power option and I also suggest you disable windows fast start (google how to do this).  Also go to your device manager and make sure all your usb ports have power savings disabled.

 

Anyway give all that a go for starters.  If everything is good and you still have headroom you may want to try moving the res slider up a notch to the right to 1.1x. 

 

If things are still a bit messy the first thing I suggest you try is to remove your guardian history, then remove your controller controller batteries and replace them with fresh ones, then restart everything and redo your guardian (start off with stationary).  Next thing would be to download the Oculus desktop app from the support website and run a Repair.  If this does not help, as a last resort I'd do a Q2 factory reset.  If this does not help then start a new ticket with Oculus Support and send them your log files.  You can also send them a link to this thread so they know who to blame, lol!  Good luck mate and cheers.

 

i9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, Q2 w/Air Link, Vive Pro

View solution in original post

12 REPLIES 12

Robot_Isnt_Real
Level 3

And yes, I tried making a support email already.


@Robot_Isnt_Real wrote:

And yes, I tried making a support email already.


So you sent them your log files to review as well?

 

Hard to say what to recommend when you don't list any specs like Q1 or Q2, cpu, gpu, ram, or which Link cable you were using and what did the usb speed test give you?  I kinda doubt that the official Link cable is going to make a lot of difference, but you never know I guess.

 

This is the Link cable I recommend.  It's powered by your Quest charger/cable and maintains your headset battery at about 80%.  Plugs into a standard usb3 type A port as well and costs les than 1/2 the original link cable.  I have both and it gives the same performance (2.4Gbps usb test) as my official link cable but does a way better job maintaining headset battery charge.

 

https://www.amazon.com/Kuject-Separate-Charging-Ultra-Durable-Accessories/dp/B09TN25765

 

i9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, Q2 w/Air Link, Vive Pro

Okay, sorry about literally sayin nothing, I was quite upset around this time but I know that my PC is VR ready and works with oculus, I am using the Q2, and the speed test came out as 2.8Gbps

The cable is already ordered so there is nothing I can do about that.

 

This lag doesn't feel like a hardware issue or a cable issue or any of that..it is just kind of there.

@Robot_Isnt_Real  It sounds like the link cable you’ve already used is very good if you’re actually getting 2.8Gbps usb speed test.  If your pc, hopefully a desktop, is actually PCVR ready with a Q2 then it probably comes down to settings and/or corrupted software and/or outdated drivers.  If you supply a bit more info I may be able to make a few suggestions.

 

More pc specs (desktop or laptop, cpu, gpu, ram).  Also win10 or win 11.  What quest update version and which oculus desktop pc app version.

 

Settings wise, what device graphics settings (refresh rate and res slider position) and list your oculus debug tool (ODT) settings as well as OTT if you are using this.

 

If you provide this basic info myself and other users may be able to make some suggestions.

 

While you say you’ve already contacted Oculus support, did you actually send them log files?  If not, I think this would be worthwhile to do so.

i9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, Q2 w/Air Link, Vive Pro

Okay, I am using a gaming laptop, I have a Intel i7-10750H "2.60 GHz" I have a NVIDIA RTX 2070 (Surprisingly NOT the laptop version!) My device graphics are at 72Hz and at the lowest resolution. My ODT is at 500 encode bitrate and turned off link sharpening and I believe that is all.

 

I probably didn't send them a log file, so I can try another ticket and try to send that.

@Robot_Isnt_Real  OK mate I'll try to give you settings that I think should give you the best PCVR results with your laptop PC using Link.

 

Oculus desktop pc app settings;  General tab make sure to select Oculus openxr as default runtime.  Device settings 80Hz refresh and 1.0x res slider.  Also, make sure your on the latest stable version (currently v42), not beta (currently ptc v43).  Run the Link usb speed test and make sure you are getting at least 2.0Gbps, preferably a little better.  One problem with Laptop usb ports is that they do not always supply enough power so sometimes a powered usb hub is a good idea.  Also, laptop usb ports have limited bandwidth so try to minimize the number of usb devices connected at any one time.

 

Oculus debug tool settings; set everything to default/zeros/auto except Distortion = Low, Encoding Bitrate width = 3664. Bitrate = 300mbps, Link Sharpening = enabled, mobile asw = disabled.  Make sure to restart oculus runtime services after making these changes.

 

Nvidia; use the latest 516.59 driver (best right now for rtx2000/3000 series gpu's imho) and use DDU to uninstall previous drivers beforehand (google how to do this).  Only custom install driver, physx, and HD audio drivers (do not install geoforce experience).  Nvidia 3D Global settings; with a laptop I think the top option should = prefer using the higher powered nvidia gpu (not your integrated igpu), everything else Defaults except Power = prefer max performance, below that change Quality default to High Performance.  Press the Apply button to save these.

 

SteamVR settings; set all Visuals Manually (not auto) to 100% and disable advanced super sample filtering.  Also, opt into SteamVR Beta (currently 1.23.6).  There have been some nice Q2 related improvements.  Go to your steam desktop library and right click on SteamVR, then properties, then beta, and select opt into beta.

 

Windows 10 settings; disable Hardware acceleration graphics (HAGS) and turn off Game Mode.  Also, go to your win10 power settings and select the high performance power option and I also suggest you disable windows fast start (google how to do this).  Also go to your device manager and make sure all your usb ports have power savings disabled.

 

Anyway give all that a go for starters.  If everything is good and you still have headroom you may want to try moving the res slider up a notch to the right to 1.1x. 

 

If things are still a bit messy the first thing I suggest you try is to remove your guardian history, then remove your controller controller batteries and replace them with fresh ones, then restart everything and redo your guardian (start off with stationary).  Next thing would be to download the Oculus desktop app from the support website and run a Repair.  If this does not help, as a last resort I'd do a Q2 factory reset.  If this does not help then start a new ticket with Oculus Support and send them your log files.  You can also send them a link to this thread so they know who to blame, lol!  Good luck mate and cheers.

 

i9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, Q2 w/Air Link, Vive Pro

Alright, It's 6 am as of the posting of this comment but i'll update you if the settings works. Thanks for putting up with me lol.

 

Edit 1: still early but I'm gonna try it out in my room, will edit  in a few minutes to clarify if it worked or not (I have most of the windows settings already dealt with, changed the graphics stuff in the oculus app, and finally I changed everything in the ODT.)

 

Edit 2:  Finished with testing and all i gotta say! PERFORMANCE WIZARD! You fixed all my ..other..lag issues but after a bit I have a WAY less laggy version of what i've been having. It's like a little lag from 80 fps down to 40-50 with really really bad looking screen tear. Might be a headset issue, but since noone really uses the Q2 in my family anymore and I mostly use it for link I'll try to factory reset. TYSM @TomCgcmfc 

@TomCgcmfc Okay, so the performance is actually great, and the factory reset didn't do anything sadly.

Although my only issue now is just some odd screen tear, any idea what could be causing that? It seems to have some worse effects in the right display as opposed to the left.

 

Oh! And it only really has effects when I move my head.

@Robot_Isnt_Real  Sounds promising mate.  Before you do a last resort Factory Reset try lowering your ODT bitrate down to 250mbps (maybe even 200mbps).  Also I guess you could also lower your refresh rate down to 72Hz with res slider at 1.0x, maybe 1.1x.  Also, be careful with in-game settings.  High levels of msaa can really kill fps performance.  Another trick to get some extra headroom and fewer lost frames is to go into ODT and change the horiz and vertical fov defaults 0, 0 to 0.8, 0.8.  This reduces your FOV a bit but not as much as you'd think.  Cheers.

i9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, Q2 w/Air Link, Vive Pro