Showing results for 
Search instead for 
Did you mean: 

If Oculus Software Install is not working... read on!

Level 3
This is for anyone who may experience issues along the way while trying to:

1) install Oculus Software
2) connect / prepare headset

It took me close to 24 hours and I've hit multiple hurdles, but I didn't give up; here's how I got it to work with my setup (Windows 10).

Installing Oculus Software:

On your C: drive, the first step is to make enough space; if you've already tried an install, then make sure that you delete anything Oculus from the following folders:

C:\Users\{your username}\AppData\Local
C:\Users\{your username}\AppData\Local\Temp
C:\Users\{your username}\AppData\LocalLow
C:\Users\{your username}\AppData\Roaming

Then, Windows Key and search "Storage", click on your C: drive, go to "Other", then click on (navigate to any folders with "Oculus" in name) and delete all files, then clear Recycle Bin

Disable Windows Defender firewall (domain, private, public networks)

Try again.

Hopefully, once installed, you come to the step where you need to plug in your headset. If not, do some further troubleshooting online (there are many more methods that you can try, the important thing is to not give up, trust me...);

The headset needs a USB3 port; in my case, I needed to install a USB3 PCI expansion board that I picked up from Micro Center for $20...

With displayport, if your computer isn't recognizing, Windows Key, search "Device Manager", find the section that says "Display adapters" (for me it lists my graphics card, a NVIDIA Geforce GTX 970), right click your card, "Update driver", "Browse my computer for driver software", 'pick from a list' option, switch to "Microsoft Basic Display Adapter"... then repeat this step (navigate to Device Manager, select your card, right click, "Update driver", "Browse my computer for driver software", 'pick from a list' option, switch to your card and let it update (for me, apparently it needed an update and this workflow worked)...

after that, both the headset USB3 and displayport cables were recognized...

then, for tracking... originally, I had another device plugged into the USB3 PCI explansion board that I installed; it wasn't recognizing tracking until I unplugged that other device and had only the headset in (I'm guessing it has something to do with power allocation...) (I also adjusted USB Power Management settings as seen here: )

Welp, I hope this helps someone. During the first several hours, I screamed a couple times and the first day went to bed exhausted and annoyed... but when I woke up, I promised to try again and kept trying until it works now (lesson is to not give up!)... also helpful are the Oculus setup logs located at C:\Users\{your username}\AppData\Local\Oculus\OculusSetup.txt

I hope this helps anyone reading who needs it; take care and happy gaming y'all!