cancel
Showing results for 
Search instead for 
Did you mean: 

Is the Oculus App causing my graphics card to show Code 31?

LandonMeadows
Level 3

I got my new gaming PC on January 15, but one time in my Oculus App, Oculus told me to install new drivers for Oculus for it to keep working or something, however I didn't have the Oculus Quest 2 plugged into the computer, but I installed them anyway.


Since then my "AMD Radeon RX 6700 XT" has been showing this message. "This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)"

 

My theory is that the Oculus App installed the drivers into my graphics card and messed it all up.

I didn't notice it until now and the only functioning graphics card I have is "AMD Radeon(TM) Graphics"

I can't even go into the AMD Radeon Software app!

 

I tried rolling back the graphics drivers but the option to do so was gray.

 

I scanned for hardware changes but nothing popped up.


I tried updating it but it said I already had the best drivers, I even tried doing it manually but there was two types of the "AMD Radeon RX 6700 XT" and didn't know what to pick so I cancelled it.

So can someone PLEASE tell me how to fix it, or tell me if Oculus did it or not.

1 REPLY 1

OculusSupport
Community Manager
Community Manager

Hey there, LandonMeadows! We appreciate the troubleshooting you've tried so far. Please try to uninstall and reinstall the Oculus home app on your PC and make sure you're using Windows 10. If this doesn't work then reach out to us via private message, and we can look into this further. Please select our name to get to our profile page, or click here: https://metaque.st/CommunitySupport. Next, click "Send a Message" to privately message us!