cancel
Showing results for 
Search instead for 
Did you mean: 

Issue with Quest 2 Air Link.

IPunchBabyz4GOD
Level 2

Decided to play VR this morning before work. Launched my system and my headset as usual. Launched Airlink and received "Oculus has detected a problem with your graphics drivers. Learn more." Following the link takes me to the page advising me to update my drivers. Alright. All my drivers are up to date. Restarted my system and received the same issue. I then moved on to reinstalling my drivers. In the process of reinstalling the drivers, NVidia GeForce experience broke itself(? Unrelated). Spent 2 hours attempting to repair drivers. Fresh install of my graphical, PhysX, HD Audio, and USBC drivers. restarted my system, and encountered the same issue. Reinstalled the Oculus app as well and got nowhere. My last attempt was to enable the beta branch and received no solution.
-----------------------
Specs as follows:

OS: Microsoft Windows 10
Motherboard: MS-7B07
CPU: AMD Ryzen 3 2200G
RAM: 16GB DDR4
Graphics Card: NVidia GeForce GTX 1660
--------------------------------------------
I currently do not have a USB-C rated cable, mostly because I find them intrusive and had issues when I initially GOT the headset, where-in I could not use the standard link function, air-link worked flawlessly. I am at my wits end and I've been at this for nearly 5 straight hours now. Any help?
Edit: While the oculus app informs about my apparent graphical issue, my headset simply places me in a black void with no audio. My guardian circle is still beneath me. 
Edit 2: Bought a cable when the shops opened, Same issue running the cable. Still black screen, no audio, can see my guardian.

8 REPLIES 8

jagsubterra14
Level 3

I have had this same problem on my rift s and quest 2 since yesterday.

reKAST
Level 2

I'm having the same problem.  Followed the exact same troubleshooting path and still no solution.  I hope this gets resolved quickly.

TomCgcmfc
Level 15

@IPunchBabyz4GOD  Wow, just another one-post-wonder, lol! If you want better PCVR with you Q2, get a better PC, and get a recommended link cable imho. Really not to hard to find recommended setups imho.

i9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, Q2 w/Air Link, Vive Pro

Don't need anything else mate. Run H3VR and B&S at 120 just fine. My issue is that Oculus refuses to detect drivers.

zasada8
Level 3

There are at least three threads about this "Oculus has detected a problem with your graphics drivers." error, and it came out of nowhere for everyone involved. So I think it's safe to say that this is a problem on the Oculus app and not on our end.

JindoGamedev
Level 3

Just wanted to relay this other thread that seems to have the solution, I just checked and I do have this program called Overwolf installed, apparently uninstalling it and restarting your PC will fix the issue, https://forums.oculusvr.com/t5/Oculus-Quest-2-and-Quest/Oculus-has-detected-a-problem-with-your-grap...

redki
Level 3

My two cents,. The following tip helped me , so it may help you.

 

I suppose that you have 2 differents GPU (like a Radeon in Ryzen APU for low power activity, and your Nvidia GTX 1660 for high performance)
In case that all checks has been done (hardware compatibility, driver update, cable test etc...) ,and you succeed to set the correct GPU for the correct process (like set Nvidia for process OVRServer_x64.exe)and all is ok, but you still have the black screen with white dots.


So, you may try to go to "device manager" in your windows, then in "display adapters" do "disable" your AMD display adapter. That will force all process to use your NVidia GPU.

Then when Nvidia succeed to take over your Windows graphical session (less than 10 seconds), you have to re-enable your AMD GPU (in short you diable then enable your AMD GPU)

 

Then from your Quest helmet  start "Oculus Link", your should reach after few seconds ( env 10 sec) your "Oculus Link" Lobby (Gray matix environment with floating Windows)

 

(this tip must be executed once after each Windows fresh boot. )

 

Hope that help, 

I have tried everything I could find online about this issue and was about to give up. This was going to be the last thing I tried, and it worked! I don't know what caused the issue in the first place but this answer should be more widespread.